Getting WiFi working

I was following the guide here, and ran into an error.

The problem is stated in the instructions, but I am not sure what to do about it.

If you see an error about NPF name, try disabling all adapters other than the one being used to program the radio. If only one adapter is found, the tool should attempt to use that one.

I am not certain how to disable all other adapters. I tried turning WiFi off, which did not work. The utility finds 3 adapters (1) the adapter connected to the WiFi router (2) VirtualBox’s network adapter (3) what I think is my WiFi card.

If necessary, I can upload the image of the actual error(s). I was able to obtain at least 3 unique error messages by manipulating various settings on the utility.

Network and Sharing Center -> Change Adapter Settings. Then you can disable other network adapters by right clicking them and clicking disable from the drop down. You’ll need administrator access to do this however.

If that doesn’t solve your issue, upload some pictures and I’ll take a look.

In addition to Disabling all those other network connections, make sure you are using the latest 17_2 version of the FRC Radio Configuration Utility. It was released after the utility available at kickoff to fix another NPF issue.

FRC Radio Configuration Utility 17.2 (1/8/17)