Gradle RIO build error


#1

Alright today i tried to do a build deploy to test the VS Code. I was never able to successfully deploy because i had issues with GradleRIO not being found in the directories that it was supposed to be in. I have tried this on an old Windows 7 laptop and it has worked with no problem. I have set an Environmental Variable for GRADLE_HOME, but still the same error. Any help would be greatly appreciated and thanks in advance!


#2

What exactly were the errors you were getting. Post them here and we can help.

In order for things to work, you need the folder with build.gradle, and gradlew.bat opened as the root folder in vscode. It can’t be in a subfolder.


#3

Just wanted to make sure, did you follow the steps to install the frc 2019 development environment?


#4

Yes, i followed the WPIlib screensteps, that first led me to the download page.


#5

We had the same issue. The first time Gradle ran it was trying to reach an external server to finish installing, which was being blocked by the school’s firewall. Once it was let though it installed properly and was able to run offline for subsequent attempts.


#6

We did notice a bug in the first release where fully offline for the first build on a system didn’t work. We are fixing this in our next release, but that’s the workaround for that issue.

I don’t know if that’s op’s issue, I would need a full log to know.


#7

Ok, so i was just trying to build the code again, and got no errors with a build being succesful. I have been fighting with those for 5 days now, and when i just started the program right now, it worked without a hitch. So if i get the Gradle error again i will post it in here.


#8

I think that was the issue here also. Everytime i tried this i have been on the school wifi, considering at the moment i am living at this place between school and build season. But i decided today to use my hotspot, and it worked. So i wonder if this is just a one time installation, or to be safe should i always just connnect to my own network, and throw up a hotspot.


#9

It should just be a one-time thing. Once the dependency is successfully downloaded once it’s cached on the local machine and available even if the machine is offline.


#10

Alright, just an intial download then. Thanks for the help, and i will be sure to spread other news of it to the teams i talk to in case they have this issue.