GradleRio can't Find the RoboRio

I’m trying to deploy our code to the rio from the VSCode software and I’m not able to get the code to go into the RoboRio. I’ve tried over the radio connection, through usb connection, and through ethernet connection. The rio is on and everything, and I have updated and reformatted it several times.

What is the complete error message? It sounds like your Rio may be formatted with the wrong image version.

Here is the whole error message:
Missing Target!

Are you connected to the robot, and is it on?

GradleRIO detected this build failed due to not being able to find “roborio”!
Scroll up in this error log for more information.
The terminal process terminated with exit code: 1

That’s not the complete message. Scroll up and there is quite a bit more, including messages about the Rios it’s trying to reach and why it can’t reach them / deploy to them.

I’m sorry but I closed out of the software on accident trying to update the Rio again.

Most of the time when we get this message the project and Rio image versions don’t match or are incompatible. When you scroll up and look at the message you will see something along the lines of in red txt

Roborio version incompatible […V2019.xx allowed]

Run the WPILib check for Updates utility and try again.

I ran the update utility and it said there wasnt any updates found, but i can try again.