GradleRIO Deploy "No Robot Code"

I was trying to build and deploy my team’s robot code and a configuration file using GradleRIO, and the driver station indicated no robot code (red light in the “Robot Code” field).

I checked the RoboRIO’s file system and my FRCUserProgram.jar and configuration file were both present, however the driver station did not recognize the code I had deployed. I deleted those files and redeployed to make sure they were not from a previous deploy, and the GradleRIO deploy definately successfully sent over the two artifacts.

I tried again with an empty project containing the code autogenerated by the FRC Eclipse plugin. The Eclipse plugin’s ant script successfully deployed the empty project’s code and I was able enable the robot. However, when I used GradleRIO to build and deploy the empty project, the artifact was sent to the RoboRIO but the driver station did not recognize that code had been deployed (same symptoms as when I deployed my team’s robot code).

The gradlerio.robotClass and properties in my build.gradle file match the package name of the robot class and the team number in the driver station, so I do not think that is the issue. Other than changing those two properties, my build.gradle for the empty project is identical to Jaci’s template build.gradle (the one provided in GradleRIO’s release).

I am building and deploying in git bash running in IntelliJ if that makes any difference.

Has anyone else experienced this problem? Any help on this issue would be appreciated.


You can check the RIO log file for program diagnostic errors.

I checked the log file, and the only thing in the file was recording of the jar being executed.

After closing and reopening the driver station and deploying again, the driver station showed the following error:

WARNING: Robots don’t quit!
ERROR: Could not instantiate robot org.usfirst.frc.team0449.Robot!
âž” Launching «’/usr/local/frc/JRE/bin/java’ ‘-jar’ '/home/lvuser/FRCUserProgram.jar’»

This is an error my team has seen before that occurs when static initialization fails, however since the same code worked in the wpilib Eclipse plugin deploy, I still do not see where this error is coming from.