GRIP code gen on RPI3

I have been trying to get OpenCV setup on my RPI3 while following the steps outlined in the readme on github. I am able to install numpy and pynetworktables with no problems at all. However when I try to install OpenCV with the line

sudo pip3 install opencv-python

I am told, “No distributions found at all for opencv-python”.

I am running Jessie Lite and made sure to install Python 3.4 aswell. Has anyone else run into this issue or see where it is I’m going wrong? Note that my experience with the RPI in general is limited, so if I haven’t found it in the GRIP ReadMe’s, I probably haven’t done it.

It looks like you need to skip ahead to the “Binaries” section of that readme.

If that doesn’t work, try to more in-dpeth approach described in the articles I link here. It will take much longer, but I the python one does work.

Edit: Note that I have not tried either of these with Jessie Light.

I got the same error. I just used the instructions posted by Adrian over at PyImageSearch: Worked perfectly.

PyPi doesn’t support binaries for the raspberry pi (or maybe even ARM at all).

I’ve built OpenCV python bindings for the pi 3 available here under the ‘python’ directory. (This will not work for other raspberry pi’s – only the 3!)

Just follow the instructions in the ‘Binaries’ section of the README](

This does not work for me. When I call the command, nothing appears to happen. It just goes to the next line in the terminal.

Which command did you run?

python3 -m wheel install opencv_python_rpi3-3.1.0+39f5a48-cp34-cp34m-linux_armv7l.whl

Ok. So upon trying to run the wheel command using the following:

sudo python3 -m wheel install ~/GRIP-code-generation/python/libs/opencv_python_rpi3-3.1.0+39f5a48-cp34-cp34m-linux_armv7l.whl

I receive the following error:

Traceback (most recent call last):
  File "/usr/lib/python3.4/", line 170, in _run_module_as_main
    "__main__", mod_spec)
  File "/usr/lib/python3.4/", line 85, in _run_code
    exec(code, run_globals)
  File "/usr/local/lib/python3.4/dist-packages/wheel/", line 17, in <module>
  File "/usr/local/lib/python3.4/dist-packages/wheel/", line 14, in main
  File "/usr/local/lib/python3.4/dist-packages/wheel/tool/", line 356, in main
  File "/usr/local/lib/python3.4/dist-packages/wheel/tool/", line 299, in install_f
    args.wheel_dirs, args.force, args.list_files)
  File "/usr/local/lib/python3.4/dist-packages/wheel/tool/", line 221, in install
  File "/usr/local/lib/python3.4/dist-packages/wheel/", line 326, in install
    raise ValueError("Wheel file {0} would overwrite {1}. Use force if this is intended".format(k, dest))
ValueError: Wheel file opencv_python_rpi3-3.1.0+39f5a48.dist-info/metadata.json would overwrite /usr/local/lib/python3.4/dist-packages/opencv_python_rpi3-3.1.0+39f5a48.dist-info/metadata.json. Use force if this is intended

I am running Jessie Lite on an RPI3. The only things I have done on the Pi (in said order) are:

sudo Apt-get install python3
sudo Apt-get install python3-pip
sudo Pip3 install wheel
sudo Apt-get install git
sudo Git clone
sudo python3 -m wheel install ~/GRIP-code-generation/python/libs/opencv_python_rpi3-3.1.0+39f5a48-cp34-cp34m-linux_armv7l.whl

Any suggestions?