how to download and open grip?Thanks

Here is a link to the GRIP tutorial, which also has a link the the Github repo for downloading it. What are you trying to do?

Thanks a lot,I am trying to study Grip.l’ll try to follow your steps.:slightly_smiling_face::slightly_smiling_face::slightly_smiling_face::slightly_smiling_face:

What are you trying to use GRIP for? GRIP hasn’t been updated in over a year and I don’t know if there are any plans to update it going forward. Using a RaspberryPi and Photonvision seems like a no brainer to me in most cases instead of GRIP.

At first,I observe some teams use Grip ,but I can’t do it well.I may try your solution. Thanks.

Is it possible to use photonvision with the Romi? That Is why we are currently ysing Grip. We have a limelight, but do not want to let that go home with students.

1 Like

Assuming you’re using a Raspberry Pi for your Romi, I want to say yes, given that PhotonVision is designed to run on a Raspberry Pi.

Thanks. Does it replace the wpilibpi image though? Or does it just change the uploaded vision file like GRIP?

You’ll need to install it outside of the WPILibPi frontend, but it’s as simple as SSHing into the Pi and running the install script. (See here for more information)


This should probably be a separate thread. What credentials do you ssh in with? Is the best way to get it internet to hook up to the pi ethernet jack?

yeah you can hook it up via ethernet (or with the WPILibPi romi image, set the wifi to bridge mode).

Usual default credentials are pi/raspberry as the username/pw

1 Like

Is this expected? How do I handle it?

ah! easy way is to open the web UI and select “Writable”


How does the accessing the interface work here? If I go to I still get the Romi. If I go to or http://photonvision.local:5800/ neither are found.

Should be http://wpilibpi.local since the pi’s image is still WPILibPi

Did you ever get this working? I just tried and am stuck in the same spot. I also wonder how to get the data back into the simulator.

Edit: I did try your suggestion in this thread to no avail. I am not getting any errors either.

You also need to make the filesystem writable by default, as PhotonVision doesn’t know how to handle a read-only filesystem. This involves editing /etc/fstab and changing / from “defaults,ro,noatime” to simply “defaults,noatime”.

Newer versions of PhotonVision on newer versions of the Romi image should “just work” with NetworkTables.


Thank you. That is easy enough. When you say newer versions, do you mean moving forward, or currently? I am running version 1.1.4 of the Romi Service and 2021.2.1 of the image.

Currently. Those should work. PhotonVision needed to make the same change we made in 2021.2.1 with the vision example programs (run NT StartDSClient).


I did get this working. When you say you are “stuck in the same spot” what spot is that?

Here is the very simple Ball Search command that I made to test things out. You will need to install PhotonLib if you haven’t already.

I created a PR to the Photon docs to add this guide for installing PhotonVision on a Romi.

1 Like