GUI stopped working

I’ll go ahead and admit off the bat that this problem is pretty bizarre. So, I am using a CMUCam2 with the Labview GUI. I was able to send about a dozen commands through the GUI… I even dumped a few frames. Now I can’t get it to do anything. I’ve cycled power on the camera, and rebooted the computer. Nonetheless, anything I try to do is met with error -1073807339. What’s weird is that if I connect to the camera in a terminal, everything works fine and looks fine. It also still does what it’s supposed to with the “bells and whistles” code. Even more unusual is that I went through this same process years ago with totally different hardware and software. In 2005, I connected that year’s CMUCam to a different computer, and used the Java GUI to dump some frames, move the servos, and such. Then, after a few minutes, it stopped working, and I could never get it to respond in the GUI again, even months later. Is there some kind of magic reset process that I need to do to be able to work with my camera in the GUI? Is this a common problem, or do I just have exceptionally bad luck?

To get rid of the error try increasing the serial port delay… i forget what its called but its the number incrementer to the left of the error display box… increase that and it should help solve the visa error

I have tried that, but it hasn’t helped. Also, the error number that I’m getting is not the same as the error that it says the serial delay is meant to fix. Any other ideas?

Have you always had this problem, or did it just start happening… you could try reinstalling labview. Also, are you sure you are using the latest GUI?

I installed Labview and downloaded the latest copy of the GUI yesterday. It worked for maybe fifteen minutes before giving up the ghost.

Yeah, that’s one messed up problem. The error code you provided is just a generic timeout code, you probably got it while waiting for the camera to respond to any number of commands.

Usually I see this when:

  1. I have the camera hooked up to the RC via the TTL serial port AND to a laptop/desktop via the regular serial port. I don’t know all the reasons why, but the camera cannot perform double-duty out of both serial ports at once. Just having them connected sometimes gives me that problem, whether I’m using it or not.

  2. I have a low battery. The camera will sometimes not respond to queries when I have a low battery, or will take too long responding to queries (or the data from the query is not good).

  3. The communications from the Camera to LabVIEW is noisy. Unfortunately the communications process isn’t very forgiving - if there is any noise in the system and the program doesn’t get back everything it expects, it may keep waiting for what it expected even if it shouldn’t expect to receive it again. Replacing the serial cables and/or converter and/or other system parts may help.

  4. My installed software is hosed. Yeah, sometimes I can’t get LabVIEW/VISA/MAX to recongnize certain devices in my system, even when the drivers are loaded and running. Try downloading/installing NI-DAQ version 8.5 - there are always fixes/patches to software and it’s a great way to clean up corruption.

  5. Let the magic smoke out of my camera. Yeah, I did this once. Wasn’t pretty. Learned to use proper power supplies from there on out. :rolleyes:

  6. A short in the system causes the camera to not respond to certain commands. We actually had this problem (with some other problems) 2 years ago - we had a servo that was bad connected directly to the camera. We could get the camera to respond to some commands, but on others it would just flip out or reset. Took us a while to figure out.

If you’ve got nothing connected to the camera except for power and the serial cable to the computer, and you know for a fact your power is good, and it still does not give you anything, it would be nice to know what command it’s timing out on. If you can communicate via hyperterminal, can you verify that it responds properly to the most common portions of its command set?

Let me know if you want me to dig into this deeper, or if you’ll be in Atlanta next week I can probably drop by a pit and check it out.