Guidance/Instructions for Importing Infinite Recharge Field CAD Into Onshape

Good evening. Mentor for FRC Team #7464 - ORION here.

Has anybody had any luck successfully importing the FRC 2020 Infinite Recharge Field CAD data into Onshape?

I tried a few weeks ago, getting the data from https://www.firstinspires.org/robotics/frc/playing-field. I believe I tried the SolidWorks and Autodesk Inventor versions.

When I tried to import them into Onshape, I got a “root document not found”, or something similar.

Can anyone share if they have had any luck importing into Onshape? And how they did it?

Thanks!

The field CAD is available through MkCad. Link

As to your actual question, if you’re importing a ZIP file of Solidworks or Autodesk parts, the zip file needs to have the same name as the root assembly. For the field, you would want to call it “FE-2020.zip”

Thank you! I was able to access the field via the link.

Also, thank you for the renaming the zip file instructions. This is our first year using CAD, so importing the field was a little more difficult than I thought.

Appreciate the help!

@techplex has a variety of configurations available and @Billfred has a stripped-down version.

Thread

Thread

All that great stuff and more is linked here, FYI: All the INFINITE RECHARGE resources

1 Like

Thank you for sharing with everybody!

Thank you again for the tip on renaming the zip file. Where I had gone wrong in the past was that I was renaming the base zip file INFINITERECHARGEField.zip to FE-2020.zip. I got the same error as I did before on Onshape:

FE-2020.zip failed to translate:
Root assembly file not found. 
Ensure zip file name matches root assembly name 
and the archive does not have folders.

It was the “archive does not have folders” that clued me in.

Within INFINITERECHARGEField.zip is ANOTHER zip file called “2020 Field CAD _ TU 10 _ 02072020.zip”. Within that archive is a folder called “2020 Field CAD”. Rename “2020 Field CAD” to “FE-2020”. Then make a zip file from that folder called “FE-2020.zip”. That zip file should only have the Solidworks files in them, with NO FOLDERS.

Log into Onshape, and find a place to upload the “FE-2020.zip” file. Click on the “Create” pulldown menu, and choose “Import Files…”. Select the “FE-2020.zip” file. I chose “Import to a single document”, and did not select “Orient imported models with Y Axis Up” or “Create a composite part when importing multiple or non-solid bodies”.

Hit OK, and after it is done uploading, you’ll get a “Saving…”, followed by an “Importing…”. I got the following message when it was all said and done:

Translation completed
FE-2020.zip was translated with errors. Parts with faults have been imported.

Hopefully this will help anybody wanting to know how to do this in the future.

Again, thank you very much for the help!