Have to restart DS laptop to get communication

Whenever we power cycle the robot, we have to restart the driver station laptop to get communication. Is anyone else having this problem or has a solution?

Thanks! :slight_smile:

I would try to set the roboRIO to a static IP of Out of curiosity, why are you power cycling your robot?

Our team is having the same problem. We may power cycle our robot for any number of reasons, but usually it’s to change something on the robot.

The same thing happens to us when we upgraded to a new laptop. The quickest way we found to solve this is just to disable then enable the wifi adapter. I made a program to do it so I could just click one button. But I’m wondering if there’s any way to fix this?

Some laptops have difficulty with self-assigned IP networking. Generally, if you wait a bit it will decide to reload the interface, build routing tables, etc. But sometimes you need to disable/enable the interface or similarly nudge it. While a bit annoying, it is quicker than a reboot of the laptop.

You may want to go to your laptop vendor’s website and see about getting updates for your network driver. You can also do this within the device manager.

Greg McKaskle

My team is having the same problem with our new laptop. orangelight, would you be able to share your program with me? It would make things so much easier. Thanks