Having a major problem w/ code!

For some reason i can not find this file!:frowning:

C:\Documents and Settings\Teh Pwnerer\Desktop\School!\Robotics\Pervious Years\2005\frc-code-1-12-2005v2.4\FrcCode2005v2.4\user_SerialDrv.c:30: unable to locate ‘stdio.h’
error 1 spawning c:\mcc18\bin\cpp18
Halting build on first failure as requested.

where do i start first? mcc18?

First two things that come to mind:

  • C-BOT (the compiler) has a 64 byte limitation on file names. Your path is quite large, try moving all the files into something smaller (I have C:\FIRST\Code)
  • Make sure that all the project paths are set correctly. I’m not too sure how to do this without having MPLab in front of me, but I’m sure if you search around you’ll find an explanation.

naw dont wrry about it … ima talk to a couple of ppl to get my set up w/ all the code cuz im soo confused w/ all these different ways of doing it:p srry for the confusion

You project location is way to deep
try moving your project to like
c:\robotics\06
and recompile, you cant go over like 94 characters or something like that

[edit]sorry, didnt see mike already stated this[/edit]

i’m no expert but could it be that you just speled something wrong? shouldent it be studio.h?
/forest

lmao … possibly… im not too sure… this is like last years code… and the programmer graduated … MAYBE! :D… thanxs

“stdio.h” is common, abbreviation of Standard I/O. It includes things like printf().

NO!! It is definitely stdio.h.

The problem is most likely that your MPLAB include path isn’t configured correctly. We don’t use MPLAB so I don’t know where the settings are, but I’m sure somebody here will be able to help.

In MPLAB check
Project -> Build Options… -> Project
then on the popup see if “Include Path” is set to c:\mcc18\h

That’s where stdio.h is to be found.

yup i have that … still getting that error tho… for now… im just gonna get rid of it … so that way i can work on some other stuff… if any could find out anthing plz let me noe:)

I was having the same problem, and this completly fixed it! Thanks sooo much!

I have to repeat this, try moving your project to a location like c:\code\06 if the path is too long you won’t compile.