Having an issue with VEX robots

Hey CD,
I recently bought a VEX kit and received it a few days ago, but I am currently having some issues and I’m not sure what to do, so I’m hoping that someone can help me. Here’s what happened: I put together my first robot, just a simple 2 motor drive train and default code, and it worked completely fine. I then put together a 4 motor drive train and made a modified version of the default code where I changed the part about 2 motor tank to 4 motor tank. For some reason, after I changed to that code only tether mode worked, not wireless. Then I thought I had to do something with the master code, so I downloaded the master code onto the controller. Then I tried downloading that master code onto the cortex and it asked for an access code, which I wasn’t sure what to do with. Now the controller won’t connect at all to the cortex, and I can’t download code at all.
Any help would be greatly appreciated!

Unfortunately, I can’t answer your question, but the VEX community has a pretty solid presence on the VEX Forums, they might be able to provide a quick answer/suggestions.

  • Sunny G.

I was thinking about posting there, but since I have a CD account I figured I’d start here. If I don’t get an answer ill try VEX forums.

You need to use the Vex Cortex firmware upgrade utility and actually give them a call on the telephone during business hours when it says Invalid ID and asks you for a code. They’ll give you the code over the phone, and you’ll be back up a running right away. This issue is very frustrating and something that Vex needs to fix. I’ve had it happen on two Cortex controllers. I should never have to call someone during business hours to download code to my robot. In the educational environment for which this product is intended this is a nightmare.

As for tethered vs. wireless, if you’re using RobotC you might need to make sure the “VexNet communication mode” is set to “USB Only” in order to run free of the cable. Also, I’ve had four VexNet USB keys fail that I have sent in for return. I also had one Cortex with a bad solder joint where the USB riser board attaches to the main board.