Having trouble with Deploying code

Ok, so we have been working on code for our robot and every time we deploy the code… once the download bar finishes we wait for the driver station/ robot to display that it has code. I’m really starting to get frustrated because we save the changes we make, build and deploy the code but the robot uses code that we loaded a while back even though we check the run as startup and the set at startup buttons… what are we doing wrong… is there a certain process to deploy your code every time and we are not doing it… PLEASE HELP!!! :confused: :confused: :confused: :confused: :confused:

Are you using LabVIEW or the WindRiver environment?

For WindRiver (C++) you might not be deploying the same .out file you are creating. Check to make sure.

On Saturday, one of our programmers told me that there is a four step process to load a new program. I followed the four step process and it worked for me. Did you follow this four step process? We are using the Windriver C++ programming environment updated to version 3 (01-27-09 WPI website).

  1. Select Undeploy ( top menu, Windriver, has two drop downs, Download and undeploy).

  2. Resets VxWorks. Must select main project file on left hand side and right click. Reset Vxworks is one selection on this menu somewhere in the middle.
    There is some kind of indicator message along the bottom of your menu showing you this event is happening. Takes about 10 seconds.

  3. Build. I don’t think this may really be necessary but I did it anyway and it worked. YMMV (your mileage may vary - first try it with build and then without build to convince yourself it is not necessary ).

  4. Download the proper *.out file. This is determined in a top menu Windriver drop down in the preferences submenu. Make sure you are pointed to the right file.

It takes about 30 to 90 seconds to perform the download (we were using a wireless router).

Hope this helps. This is what worked for me yesterday (after James showed me how to do it).