[Help] Can ping, but DS says "No Robot Communication" only W7, ok from XP

bringing a new mule cRIO board online. Got the cRIO imaged, have had several weeks of successful use from my XP laptop.

Trying to bring my wife’s laptop (Windows 7 Home) online. I disabled Windows firewall, shut down the wireless, connected the ethernet on the laptop to the cRIO with a crossover cable, configured the Ethernet to static 10.te.am.5 with a 255.0.0.0 netmask. I can ping (and FTP) 10.te.am.2 just fine, and the lights on the cRIO ethernet port indicate that packets are merrily going back and forth.

I bring up the DS, and it still says “No Robot Communcation”. The Diagnostics Pane shows green for both the Enet Link and the Robot however.

What am I missing? I believe the Enet Link and Robot are green if things are pingable, where the “Communications” light is driven if the DS is receiving packets; this differennce is what made me double check the firewall settings.

I am stumped. Again, the XP laptop is fine, and I can ping and FTP the cRIO from the Windows 7, just can’t get a green Communication Light from the DS.

Try starting the Driver Station app from the right-click menu using “Run as Administrator”.

thanks for the response.

Running the DS as administrator did not help. Still showing green for Enet Link and Robot, but a Red communications light, along with “No Robot Communications” in the LL corner.

Team number entered in the Driver Station app matches this cRIO’s Team #?
Is the DS set to override/set the local IP automatically?
DS version is 11.30.11.00 (I think)

You said the cRio was new: have you already flashed the image on the cRio?

Mark: Team number matches, have run both manually setting up the interface and letting the DS do it. I’ll double check the DS version, and will also deliberately screw up the team # to see if behaviour changes (I think that will make the Robot light go red because the pings will start failing).

Tom: yes, it’s imaged, and works perfectly from my XP laptop…

I checked and I have the Driver Station app running without issue on:

  • Windows 7 Home Premium
    *]Windows 7 Professional, SP1

Is it possible that you have a proxy set in your internet settings? (This causes us headaches from time to time).

proxy was set. turned it off, didn’t change things.

I deliberately changed the DS team number to an incorrect one; that causes Robot light to go red (expected, no response to ping…)

I did just notice this Windows 7 64-bit. Has anyone been able to get the DS to run under 64 bit?

Yes, it’s been fine. We even have someone running it on Windows 8.

ok, that’s good to know.

I’m missing something here, it’s still not working. Here’s the summary of what’s been considered and ruled out:

  • Bum cRIO?
    Probably not, works fine with XP.
  • Wrong team #?
    Probably not: ping and FTP works, symptoms change if the team number is deliberately set incorrectly.
  • Internet proxy?
    Turned off. No change.
  • bad cable?
    Probably not: ping and FTP works.
  • Windows 7?
    Other teams have W7 working.
  • 64-bit?
    Other teams have 64-bit working.
  • Firewall?
    Double checked and off.

Have you tried using a straight-through cable? Have you tried going through a router? Do you have other computers with windows 7 that have this issue or is it just the one?

I had an issue that was exactly like this, I had the DS on a computer with Vista Business SP1 that connected just fine the the bot and always had comms but my personal laptop with 7 Pro x64 wouldn’t show the robot as having comms or code. I don’t know what caused it but I worked around it by reinstalling windows, labview, and the DS.

I have tried both a straight and crossover (though cable trouble was ruled out because pings and FTP work).

Did a wireshark on the PC, can definitely see the packets coming back from the cRIO, but the DS doesn’t seem to get them. Have triple checked Windows firewall, which would seem to be a likely cause of an application not receiving packets.

Don’t have another W7 box to try.

What anti-virus are you using?

Long shot…is the laptop fancy enough to have two network ports? If so, have you set the DS to use the correct one?

Either way, I would hit the Choose NIC… button on the DS Setup tab, just to see if there is anything illuminating there.

Joe Ross: hadn’t thought of that. Running AVG Free 2013; disabled it, no joy.

gnunes: only one ethernet port. double checked, wireless is disabled, wired enabled on correct port, ping and FTP work.

So still in same place: Communications lights on diagnostics panel shows “Robot” with a green light, I can ping and ftp the robot, but DS stills says “No Robot Communications”. If I put a bad team number into the DS, then the "Robot"light goes red (as it should), and if I have the correct team number in the DS, but disconnect the cable, the “Robot” light goes red (as it should). I definitely have TCP/IP connectivity between the W7 box and the robot (green Robot light on diagnostics panel, ftp and ping work).

Who knows the difference between the green Robot light and the “Communications” light?"

I’m about to give up and start over with the 2013 DS in a little over 2 weeks; maybe the problem will go away then (or FIRST will be able to tell me how to get more troubleshooting information)…

Ooh, ooh, I know…

The Diagnostics page LEDs in that column mostly refer to ping results. The No Robot Communication message, and the light on the left permanent panel labeled Communications are much more of a summary and indicate whether the protocol is succeeding.

My guess is that the cRIO is not running the FRC Communications task and is not responding to control packets. Image the cRIO. You can verify this further if needed by using netconsole or the serial cable to view the console trace. You could also identify if that task is running or not. But since most folks don’t have a null-modem serial cable laying around, I’d reimage and see if the issue is resolved. Be sure to click the format checkbox in the imaging tool.

Greg McKaskle

cRIO is running the task; swapping my XP machine in makes everything work perfectly. It’s something on the W7 box…

Is there any chance you are also using both a wireless and wired network connection?

Do both have the same domains, or do they both start with 10.xxx.yyy.zzz and you have a subnet mask set at 255.0.0.0?

It might be confused about which network connection to use to connect to the cRIO.

If so, try disabling your wireless, and go wired only.

Strange, because if you can ping it, it should be fine.

How are the ping times? any dropped packets?

Maybe you can try a “tracert” and see if anything fishy is going on.

It still sounds like the FRC port traffic for the Driver Station is being blocked (or the port is locked up) by something on the Win7 machine (for your own security, of course).

You might scan from another machine to see what ports the Win7 machine has open using something like Angry IP Scanner

You’ve already eliminated the usual culprits - Windows firewall, anti-virus, extra NICs, intermediate router firewalls.

No other network related applications on the Win7 machine?
Perhaps booting Safe Mode with Network would eliminate the possibility of a third-party driver causing the conflict.