HELP!!!! EasyC Compiling Issues

My programmer on my team is having trouble compiling his code.

Whenever he tries to compile it, he gets an error box that says “There were compilation errors! Check the ‘Output’ window for details.” However, when we check the output windows, alas…there ARE NO ERRORS!!!

We’ve tried even compiling a blank code and get the same thing…

I’ve uninstalled ALL programming programs from this machine and reinstalled them. Does this sound like anything that anyone has seen?

Any ideas?

Thanks in advance!

Please be sure you are using the compiler that came in your kit of parts, and not the newest version from the internet.

Let us know,


I have MPLAB C18 compiler v2.2 and my sponsor has convientiently misplaced our MPLAB CD…so I can’t get v2.4. I have a hunch that this is the problem, however, I am not able to install v2.4 anymore…

Can I download this anywhere? I’ve looked on Microchip’s website and can only find v3.0

You can not download it anywhere. I have it, but I don’t know if we are allowed to share it or not. I got it last year when Microchip gave us all access to it with a FTP password.

I think you can still get the compiler v 2.4 by visiting the microchip website, going to the C18 v 3.0 download page and finding the link to the previous versions archive.

You will need to use version 2.4 to compile correctly.

You can also purchase a replacement CD from

Actually I did find the one on the archive page but when I attempt to install it, I get an error that says that the install I have is not upgradeable. The only remaining v2.4 download on Microchip’s website IS the upgrade. We have located our CD though so I plan on trying that this afternoon…We’ll see what happens…

Hi, I am new to Delphi. Last year was my first year. I am having compiling EasyC and installing MPLAB.

The EasyC compiler reports => Couldn’t locate build tool. Would you like to check compiler locations?
This occurs when compiling. I then tried to install the MPLAB IDE which reported the following error:

Error 1935. An error occurred during the installation of assembly
‘Microsoft.MSXML2,publickeyToken=6bd6b9abf345378f”,version=”4.20.9818.0”,type=”win32”,processorArchitecture=”x86”’. Please refer to Help and Support for more information. HRESULT: 0x80070020.

The old version of the IDE was installed and I installed the new version over it. I have since tried many combination. I need help!!!

Delete your MCC18 directory. Also make sure you install MCC18 into C:\MCC18