[HELP] Labview Navx library not working


#1

After running the library installer none of the functions show up/ are not in the menus or come up when searched for. I’ve tried multiple computers, 2017 and 2018 labview, and Java is up to date. Any ideas? Am I doing something wrong? The only other library my team has installed is CTRE and that installer worked perfectly.


#2

Have you checked in the sensors->third party subsection?


#3

From what I have seen it is installed into the sensors->third party directory and not the third party by itself directory.


#4

Yeah, its not there in labview, but the file is in the folder. We have even tried moving the file to just the third party subsection, and it still did not show up.


#5

It’s in neither for us, but confusingly, the file is there. We’ve tried restarting Labview and the computer with no success.


#6

Here is the process I followed to see the library:

  1. I just installed the navX libraries from: LabVIEW navX-AE.
  2. Unzipped the installer and ran it
  3. I saw the files were in: C:\Program Files (x86)\National Instruments\LabVIEW 2018\vi.lib\Rock Robotics\WPI\ThirdParty\Sensors\navX
  4. I looked in the Sensors palette in LabVIEW and it was under Third-Party there:

Does this work for you?


#7

After running the installer, the files did show up in the file location above, but dont appear in LabView. Are work around for this was just copying and pasting the Navx folder into the user library section. Dont know what caused the issue.


#8

You may need to restart LabVIEW.

You can also manually edit the pallet by going to Tools -> Advanced -> Edit Pallet Set…

Keep in mind if you have multiple LabVIEW computers and you copy the files, you will need to repeat that process on all the LabVIEW computers.