HELP NEEDED: Solenoids not firing

We are using 24V solenoids, wired into the PCM. The PCM is set to 24V, the lights on the solenoid ports (small red ones on PCM) are lighting up, and the solenoids fire manually. There is voltage going to the solenoids (we tested with a voltmeter), but the solenoids aren’t actuating.

The PCM is blinking orange when disabled, blinking green when enabled, and blinking red when triggering the solenoids. The red blinks are constant and according to the manual this means a compressor issue. We tried flipping the positive and negative on the compressor but that didn’t change anything, the compressor is still filling air because it fires manually, so I can’t see the problem. There are also no visual indications that the compressor isn’t working.

Thank you for any help you may be able to provide. My team and I would really appreciate it.

If the solenoids aren’t firing when the PCM leds say they should,

  • Check that the solenoid wires aren’t reversed
  • Check that the solenoids are getting at least 30 psi at their input port

If the compressor is not operating automatically,

  • Enable the robot
  • Jumper over the pressure switch to test if you can force the compressor on
  • Check your code and remove ALL references to any compressor (it gets instantiated behind the scenes when you create any solenoid)

The solenoids are not wired in reverse and we are firing them at 60+ PSI.

The compressor is running automatically.

Any other ideas?

Thank you so much.

I’d test moving the PCM jumper to 12v just in case the solenoids are mislabeled as 24v.

Do the solenoids have built-in indicator lights of their own that light up or should light up?

It is not impossible that the coil of the solenoids are blown. Are you sure they are 24V and not 12V - it is printed on the solenoid. Do you have another solenoid to try?

If you stop your code then manually change the solenoid, does the solenoid change back when you start the code? search the code for all statements that could be commanding the solenoids to a state.

We’ll try that too.

The solenoids do have LEDs that did light up, they were very dim though.

Thanks again.

We tried another 24v solenoid, but not a 12v one.

We’ll try that as well. Thanks!

If the built-in solenoid lights were dim, then I’d try reversing the wires even if the colors are wrong.

We’ll try that, but it’s strange because we tried the same kind of solenoids on a different PCM and different compressor and they worked fine (with the same polarity we have on this one).

I was just thinking that the dim LED could either be putting current through the LED backwards or low power supplied by the PCM.

Perhaps you could put a voltmeter on the PCM output to the solenoid - is it really 24V?

We were getting about 200mV, but we think that’s because the solenoids only fire for a short amount of time.

Try increasing the duration of your strobe so you can measure it. It is also possible that your strobe is too short for the air piloting to work, even if the electrical part switches.

I am no expert, but I believe the solenoids are not polarized. The coil is active when there is current and passive (pilot air holds last state) when no current. They even work with AC signals.

My suspicion (as raised by another post) is that the code is sending an activate signal and immediately sending a deactivate which is too fast for the mechanical solenoid to move, causing the dim light and the 200mV measured voltage. I would like to see if they can send a healthier pulse.

I’ve had solenoids that were directional.
The LED generally turns on, but the coil does not trip when wired backwards.

If they are pulsing too quickly, then that will show up on the PCM indicator per solenoid.
For a double solenoid, if the PCM light is on then the solenoid will be driven to the corresponding position. If the light is off, then the position is indeterminate. If both sides of the solenoid are tripped at the same time then it’s also not going to move.

For a single solenoid, the PCM light has to be on for the solenoid to move away from the home position. When the PCM light is off a single solenoid will return to the home position.

Good point - if double solenoid and pulse both nothing happens!!! If they are double solenoids, unplug one side and try it then repeat for other side.

We have single solenoids. This kind in particular:

We will try to increase the pulse time once we unbag our robot.

Thanks for the responses!

Problem solved.

From the data sheet:
• 2-position, single solenoid normally closed spring return;

Since it is normally closed, when the solenoid is not powered, the spring returns it to the closed position. These solenoids need you to hold the the 24V on the coil, not pulse it.

To be clear, you have the ones with only one black wart with wires, correct?

If by wart you mean thing that the wires come out of, then yes.


We tried working backwards on our other identical robot. We tested the voltage going to the solenoids forwards and reverse and it actuated with 24v. With only 12v the solenoids light up, but don’t actuate. The pulse in code is 0.25 seconds and works perfectly fine on this robot (the code is identical for both).

On our competition bot (the one that doesn’t work) we are going to oscope and multimeter the signal from the PCM to solenoid and if it is correct (24v and 0.25sec pulse) we will swap out the solenoid and if it is not correct we will swap out the PCM.