Help on MPlab

I have no clue where i am now, the code isnt compiling, and when you do try to download to the rc you get an error divide by zero. now im have no code on the rc and hove no clue how to get some on. a different programmer said try re downloading the software, but i dont know the sites to download or the complier to get, or even the right order to download. im jsut so lost


Visit the getting started thread.

I can’t help you with code unless you post what you have but:

  1. Uninstall and re-install the latest version of IFI Loader.

You can find the software at and

If you don’t have your compiler and MPLABS installed correctly, uninstall and re install correctly from the CD you got at kickoff.

its something with the complier, i havent gotten to the loading part yet,

Clean: Deleting intermediary and output files.
Clean: Done.
Executing: “c:\mcc18\bin\mcc18.exe” -p=18F8722 /i"C:\mcc18\h" “main.c” -fo=“main.o” -D_FRC_BOARD -D_LARGE_CODE -D_DONT_USE_TMR0 -mL -Ou- -Ot- -Ob- -Op- -Or- -Od- -Opa-
This version of the compiler supports only the PIC18F8520 processor.
Halting build on first failure as requested.
BUILD FAILED: Sat Feb 24 10:22:41 2007

thats the message i get with defualt code 2007

my mplab isv7.51 but it was a cd from the kickoff, how do i get the newer compiler, or is it jsut the version i have


It seems to me that the problem isn’t MPLab, it is in fact your processor. I don’t know which one, but a PIC18F8520 doesn’t sound like a computer processor, so that’s quite confusing.

That sounds like you might have an older version of the C18 compiler, not the one that came on the latest CBOT CD from this year’s Kit-of-Parts.
PIC18F8520 is what we used on the 2004/2005 robots.
PIC18F8722 is what we have on the 2006/2007 robots.

Your MPLAB version doesn’t much matter.
I’d uninstall and reinstall just the C18 piece from the CBOT disk.

that would make sense the cd i have is from several years ago,v7.51

i tried one of our 2004 programming labtops and it says unable to open file, isnt there something where the file name cant be too long?

last i dont have this years cd for the compiler at my house, is there some online download version?


The PIC is the processor inside the RC…

You’ll need the C18 v2.4 compiler from either this year or last year’s CBOT CD. There is no online or other legal source.

We’re unfortunately dependent on an older version of the C18 compiler, and the lastest version (3.x) available for online trial is not compatable with the IFI libraries we use, and will not work.

You can only use the 2004 version (C18 v2.2) with an older robot controller.
If you are just trying to use it to find compile errors, then you might be able to get by. Try creating a new project (Project Wizard) using the IFI Default Code files.

im trying to download to a 2006 controller, i jsut have so many different years on the items its not working. im working on getting my camera working, but i cant even get basic drive code on the rc

the cd i have says 2004 v 2.0

the controller i have is 2006

the code i have is 2007, i think i need the 2006 code

now i need the 2006 compiler, or would the earlier years work?


The 2004 will not work. You need a newer one, try to get the one from this year.

I’ll backup Kevin.
You need at least the compiler (v2.4) from last year or this year for it to work. It has some extra capabilities the camera code depends on.

You can run 2007 code on the 2006 controller without any problem, because those two controllers are identical.

You will need ifi_loader v1.1.
The original 2006 CD had an older loader with a bug, but 2007’s is okay.

if i run to the shop and pick up this years mplab and compiler, will it work on the 2006 controller? then i would jsut have to go to ifi robotics and download the ifi loader, correct?


If you get this year’s CD it’ll have everything you need, including the right ifi_loader.
Just be sure to uninstall the older stuff before running the install.

For the 2006/2007 robot controllers, make sure you have PIC18F8722 and not PIC18F8520 on the Select Device window in Config at the top bar.