Help--Program Light Stuck

We were working on downloading code, and it got stuck in Program mode. We reset the robot, and the program light is still orange. Whatever we do (shut it off, reset it, reset from the oi, etc.), it will not go out of this mode. And it will not accept any programs. Help!

With main power applied, press and hold the Reset and Prog buttons at the same time. Release only the Reset, while continuing to hold the Prog until the Battery Power LED becomes solid green. Now release the Prog button. Now press and release the Reset button.

If that doesn’t work, check the IFI site for more info.

Don

This may, or may not, be your fault, but there is a fault
where the program light is stuck but it isn’t really in program
mode. Hold down the program button for four seconds,
no lights will change, and then give it a try. We have had
this happen to us in the past and this was the cure.

Eugene

Unfortunately, neither of those seemed to work. Checking IFI’s site just led to the same things. We’re thinking about doing a warranty repair/replacement.

What base code are you using? What battery voltage does your OI indicate? Remove all power and let it sit for a minute or two and then try it again. In the extreme, you may need to reload the master code, which is available on IFI’s website.

-Kevin

I’ve had that happen several times. usually the methods above worked. The one time those didn’t work I let it sit for a couple of hours, then those methods worked.

EDIT: Once when IFI Loader let me download Vex code to the RC(I didn’t think it would let me do that) the only thing I was able to make work was to download the master code. Then I was able to program it.

We’re using our code from last year (based on yours). I was uploading the code from yesterday (that had worked before).

We had just replaced the battery. We replaced the battery again and it still didn’t work.

We removed the power for about 30 minutes and it still didn’t work.

Thanks, I am downloading now and will test it tomorrow.

Background: Was doing encoder development testing from a laptop USB / serial connection to robot. First time ever (5 yeards) program light stuck on. Code Error light on as well. Didn’t realize OI Code Error light always goes during program cycle so first thought of some master code or hardware fault. Been using this USB/Serial cable for years totally glitch free (though some are definitely not glitch free or don’t work at all). The laptop connection worked 100% next day on 2004 RC.

After two days of getting nowhere including leaving RC completely disconnected and multiple hard boots on laptop and another person trying the above reset techniques…
Took RC home, connected to home PC with true serial port. Program light still on.

  • Tried IFI Loader Controller Verification, verification passed. I am guessing that means that the loader was able to talk to the master code.
  • Tried Terminal Window. Every time reset or program button hit, the “IFI>” prompt appeared. Tried download and it worked and program light is now off and RC is working. Cause: don’t know, Solution: don’t know (wonderful).

Recommendation: If you are totally stuck (sorry for the pun), connect RC to a true serial port and try IFI loader verification and then look for the IFI> prompt. Try to repeat this with any 2004+ previous RC to verify the cable is working. If it won’t work on 2008 but does on previous years, call IFI!

Another glitch on our 2008 RC: We were also seeing this other glitch running Kevin Watsons 2007 merged encoder & gyro code: 90% of the time when we did a hard boot (ie main breaker turned on), code error light would be on. Every time we did a soft boot (reset button), the code error light would go out and the RC code would execute properly. Our 2004 RC is not exhibiting any of this using the same code (at least so far).