【help】Romi setting

how can I find the Pi’s internal serial number~ is that a must that i need to flash Pi’s img, and through the Pi’s system to find the information? actually, I already flashed the wpilibpi-…-Romi.img successfully, can i find it through the wpilibpi.local? any help is appreciated!!

You don’t really need to look up the number. This is just used to make sure the wifi network SSID being served from your Romi is unique in your vicinity. If you enter your computer’s wifi settings, you should see a list of available wifi networks. Look for one that begins with “WPILibPi-” and it’s probably the one you want.

Once you are connected, you can rename your Romi’s network in its configuration web page to choose an easier-to-recognize name.

Thanks, Veg~

does that mean i don’t need to do any changes?

cause my understanding for here is, we need to change two things, one is the WIF SSID, the other is WPA2 passphrase. and acutally i remember the default WPA2 passphrase is “WPILib2021!”(which means i don’t need to change it)~ and there is no need to put the serial number there, so, we don’t need to change anything here, right~

1 Like

That is correct. You can continue to use the default SSID and passphrase for the Romi, but it is recommended to change it, for security reasons.

Many thanks!

and now, new problem occurs~ :sob::sob::sob:

I did get into the wpilibpi.local successfully yesterday(see pic below), but in order to get the PI’s serial number, i formatting the micro SD card to flash the PI’s img :cry:. and now, i formated the micro SD card again and flash the wpilibpi-…-Romi.img successfully, but it can’t open the wpilibpi.local any more~ i tried 3 times, all failed~ i don’t why, i just did what i did before, but now it won’t work~ :sob::sob::sob:

any suggestions for this issues~?! Thanks!

I am not really sure what is going on there.

The Romi will take extra time to reboot the first time after you reflash the SD card, so maybe that is what is happening? Is your computer reconnected to the Romi wifi network?

yeah, i am pretty sure that the network should be ok, cause i just did the exactly same thing as yesterday. but to be honest, the things in the micro SD card are a little bit different from before(i remember there are more things in the micro card after finish flashing) and here is what 's in there now~ how do you think of this one? anything missing here ?!

it works after i change the batteries~ :joy:

1 Like

one more question:

when i do the vision setting, and when i click the “Copy Source Config From Camera”, nothing was filled in the blank

I don’t have a Romi handy at the moment, but I think you need to open the camera video feed before everything will sync up.

:flushed: one more question~

I get my romi connected to the internet by doing this(see pic below):

but as you see here, it’s inconvenient for a romi to “run everywhere” on the ground. and i am thinking get the romi connected to the WIFI (no cable should be used any more like what i did before) should be the correct way to keep continue my ROMI journey~

so my question is, how can i help my romi get rid of this cable~ :sob:

any help or suggestion is appericated~ :pray:t2:

The thing to understand is that the Romi does not need an internet connection for normal operation. Instead, your Romi will offer a wifi access point that your development computer will connect to. These two can talk to each other, but not directly to the internet without a separate connection that you don’t really need.

So unplug the network cable and connect your computer’s wifi to the Romi wireless network.

If you want to use the internet while you are woking with your Romi, you can install a second network adapter in your computer.

EDIT: After you are set up, you can also remove the USB cable connecting the Raspberry Pi to the Romi, as this is only used when updating the Romi firmware to a new version.

yeah, Thanks bro, it works~ and I tried both auto and tele, it works well~ and i am so happy to see my romi run run run away~~~ lol~ so far, i use the keyboard to control my cute romi, but actually, i want to use Joysticks to control it. I think if we do some joysticks setting on Robot Simulation, it should work, but how~?! :joy:

what i tried for now is, connect my joystick to the pc (i just found maybe it’s stupid, should connect it with romi?! cause i ust it to control my romi, right?! :joy::joy::joy: i am going to try it tomorrow, since it’s too late my time here, need to goi back home now~)

and one more question, is there a way that i can use a wireless joysticks to control my romi? ! :joy::joy::joy::joy:

Fogive me if i asked too much stupid question, a brand new rookie here~ :joy::joy::joy::joy::joy:

You can also connect to your Romi and the internet at the same time by setting your Romi in bridge mode and having it connect to your local network (if you have access to the username/password for it). You can find instructions for that at the WPIlib docs. For getting a joystick to work, you will have to configure it in the simulation window - there should be a “System Joysticks” box, and you can drag a plugged-in joystick from there into the Joysticks[0] column in the Joysticks tab. The Spectrum series gives a great overview.

Yeah, i did follow spectrum’s toturial to do the setting, and that’s why i could get my romi controlled by the keyboard, but it just failed when trying to use joysticks~ and here is my setting pic:

Your Romi program is likely coded to use Joystick[0], which is mapped to your keyboard in that screenshot. You can either add code to your project to enable Joystick[1] to drive the robot, or just drag & drop the joystick onto Joystick[0] instead.

1 Like

yeah, i changed it, it works~ but when i press “left/right” button on the joystick, the value changes in the robot simulation window, but Romi didn’t act as it supposed to be(see pic below)

the example code i used is RomiReference, i am thinking maybe this is because there is no corresponding codes for this two buttons?!

one more quick question: what does CCW and CW mean~:joy::joy::joy:

CW means “clockwise.”
CCW means “counter-clockwise.”

Also, there is a switch on the underside of the Logitech F310 controller that you may need to slide in order for the joystick to work correctly.

You should see the joystick values changing in the dashboard, and the small squares will light up to show when you are pressing buttons. If that works, then you know the joystick is working and you just need to hook it up in your code.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.