Help!!! Wi-Fi issues...

Okay, so i was trying to validate all the programs we got from FIRST and the Wi-Fi at my house decided not to work. I manually put in the IP adress, as that’s what the programming laptop saiid was the error, but it did not work.
I even plugged the ethernet cord directly into the back, to no avail.
sigh I spent three hour puzling this out and I need to figure this out.:confused:

You said you are attempting to use the system on your home WiFi system. This will not work.

Most home routers are set up to hand out addresses in subnet 192.168.1.x or 192.168.0.x (a mask). To use the cRio in the way intended for programming, etc, it will need to have an IP address of 10.xx.yy.2, where xx and yy are your team number - quite different from the subnet of your home router. When your laptop tries to send packets to the 10.xx.yy.2 address of the cRio, there will be no path to it in the local network - the router only “sees” addresses inside its own subnet as local, and will fail routing it (it’s also possible it will just discard it, depending on configuration, and it’s also possible the packets from your laptop won’t get anywhere to start with, without a properly assigned gateway in a network configured like this. I’m not a IP expert.)

Namely, the only way to use it in an environment like this would be to directly connect your laptop and cRio (that is, without cutting your internet connection at home, or vastly reconfiguring your router - if it can be, to start with. It sounded like you’ve done something with an ethernet cable, but I’m not sure what) via an ethernet cable (crossover or not, it should work either way if you have a sufficiently modern laptop). Set your laptop to have the wireless off, and your ethernet adapter with the static IP of 10.xx.yy.6 (as dictated in the guides as normal), subnet mask of

Hope this helps.

The easiest thing to do to test the system is to connect the DS, either port, to the cRio port #1 using a patch cable, and connect the computer to the other port on the DS.

If you’re using the OTB firmware on the cRio and DS then set your ip addresses to:
DS (already set) subnet
cRio (already set) subnet
Computer subnet

IF you’ve upgraded the firmware in both the DS and cRio then replace 0.0 with your team number as described in the documentation.

You can then try pinging the DS and cRio, and attempting to download code and/or upgrading firmware.

With this configuration you can verify the system works, then you can configure the wireless.

I would recommend setting the gaming adapter settings appropriate for your normal network, probably 192.168.(0 or 1).(254 or other high number) subnet

Once that is connected you should be able to connect your DS and computer and they should work without any issues.

Here is a my post to a similar question last month.