Help with cmu2gui

I’m now running kevin’s bells and whistles code and its working fairly well. His camera menu works just find and the camera will find the lights. However I am trying to use the gui from his website so I can see what the camera is seeing (I couldn’t get labview to work right). I know I am making a connection to the camera because I am getting data in the terminal but when i run the gui it flashes the black screen and then closes. Does anyone know why this is happening?

On another note I also can’t get the camera to lock onto the lights. It will find them and report back all the angles and information and then keep searching. I have tried adjusting the search delay but that doesn’t seem to have any effect. Thanks for any help in advance.

If the green LED turns on when you shine the light, the camera is tracking fine. Just no moving servos.

As for your GUI problems, I couldn’t tell you. I know the old one (from 2005) isn’t real flexible.

Thanks, we are still trying to learn the camera, as we are a rookie team

I know that the camera is tracking and finding the lights it just isn’t actually locking on to the light. Or maybe i’m just mistaken and the camera isn’t supposed to lock on the light.

If the camera doesn;t track the light, a couple things need to be checked if using the default code:

  1. In tracking .h you may have to reverse the pan and tilt sign numbers. Ours had to be reversed. If it is a +1, make it a -1 and vice versa.

  2. The camera may be mounted upside down.

  3. The servo pan/tilt inputs may be connected to the wrong inputs. look in tracking.h for pwm assignments.

Hope this helps!

Jim

If you choose a serial port that isn’t valid in the Java program, it will close immediately with no error message. Make sure you are choosing a COM port that exists. Check it under My Computer, Properties, the Hardware Tab, Device Manager, Ports.

If you have a USB-Serial adapter, and it’s working, you should see your COM port device listed in Ports. If you have a real serial port, it should also be listed under there.

–Eric

Are you saying that the camera can track blobs in its view just fine, and that the servos are not operating correctly? Or is the camera failing to track the color blob?

If it’s an issue with the servos, what is happening instead?