Hight packet loss every 15 seconds

This post is a cautionary tale…

I was getting high packet loss every 15 seconds when I was connected wireless from my laptop to the robot’s radio.

This loss caused the drive to be jerky for about 5 seconds every 15.

It did not happen when I was hard-wired via USB or Ethernet.

I (like others in the past) tracked it down to an Autodesk program that was running in the background and messing with the network… probably making network calls and blocking on the return timeout.

Anyway, I used Task Manager to locate the AutodeskDesktopApp.exe (or something like that) and when I killed it, the packet loss stopped immediately.

So… if you see this problem, you know where to look.



One more reason why teams really should have a dedicated driver station laptop. Just a clean windows install with the latest updates and the driver station program. Make sure all firewalls and security software are permanently disabled, and only connect it to the robot to avoid accidentally downloading something from the internet. Disable all automatic updates, downloads, etc.

There’s plenty of threads on here about how to get a relatively cheap laptop with the required specs to use for this purpose. It’s a shame so many teams don’t follow this advice, then get to competition and have problems like this on the field.


Treat the robot like a production system. Stay away from making many changes without testing. No development stuff on it.

Windows Updates Turned Off

I agree. In a perfect world, the robot would have a dedicated driver station laptop with no other software loaded on it, and the developer(s) have a separate machine… Yeah, that would be great… Can I go to that world? :heart_eyes:

However, as I walk around the pits at most competitions, looking for teams to help with programming, I see a large percentage of teams using their development machine to run the robot. So, reality is not the ideal. This is typically because they can only afford one decent laptop.

Also… on Windows 10, the only way I know to turn off automatic updates is to never connect to the internet. Is there another way?

You don’t need much to run the driver station so I would argue that you can get a usable laptop used on Newegg, etc.for under $500. Sounds like a lot but it would be usable for a few season so the per year cost is not prohibitive.

I would bet that there are local business that would don’t used equipment in exchange for recognition as a sponsor. We got 5 last year from a local company that had just done a equipment refresh for employees. 5 yo Dells w/16GB and 15" screens.

As for Windows 10 updates, yes you can’t turn them off but you can delay them for 7 days which is something that can be done as part of a Driver Station Readiness process before a competition. There are ways to delay it longer if you have the Pro version. Google it.

$200 can get you into a great driver station. Here’s a T440 for $139+shipping. That machine is total overkill for a DS.

There’s good info on managing Windows updates in the Driver Station Best Practices document.

Thanks for the specific references.

Thanks for the report. I was having this exact issue and you just solved it. I won’t be using any Autodesk programs on the driver station computer any more.