Holonomic Code Problems

After searching through all the old threads, I was still unable to find the solution to my problem.

My team has decided to use holonomic for this drive system. I found the default way to program it, and by looking through other threads how to connect it (I use LabVIEW). But whenever I run it, the wheels automatically start turning. My code looks something like this:



You haven’t told us anything about the setup on your robot. Please describe what wheels you have on your robot, how they’re connected to some motors, and how the motors are connected to the control system. There’s literally thousands of places that a mistake could have been made, and additionally, the term “Holonomic” is less-than-fully understood by the community as a whole, and different people will often take it to mean different things.

Just to clarify, by holomic, do you mean omniwheels, or mecanum?

It can be due to a mis-calibrated joystick.
You can check your joystick on the PC by going to Control Panel -> Game Controllers to see what it thinks the joystick is doing.

It could be due to mis-calibrated speed controllers (less likely). You can test this by temporarily changing your code to use “0” constants to feed your Holonomic Drive function. (This will also tell you if it’s your joystick input.)

If your wheels are still turning with constant zero’s in place, then it’s probably a wiring issue.

That code is for use with a joystick that can rotate. The axis3, using a standard joystick, would be for the throttle control on the joystick. if you are using a non-rotating joystick and the throttle is not exactly centered, then the wheels would move.

you could also assign the rotation to a 2nd joystick like we’re using in our code as of now, since we’re using standard joysticks.


Uploaded with ImageShack.us


This will be the next thing I will try to check. It’s possible, but I tried adjusting the joysticks. Just as a question, what should I change if that is the problem?


Uploaded with ImageShack.us

Sorry I wasn’t excatly clear. I meant to say that I had changed it from that pic, and hooked it up like 3p1c w1n has. I put the second joystick’s x axis to control the rotation.[/quote]

From the picture, it looks like the wheels are mounted wrong…the top view should look like an “X” and not an “O”.

Yup. You need to swap the left&right or front&rear wheels


When I looked up documentation on it, it said it can either look like a X or a diamond. But the problem is not the orientation of the wheels ( I will deal with that when it comes :stuck_out_tongue: ). The problem is that it keeps on running even with the joystick not being moved.

have you tried running the code without the joysticks plugged in?

If you run the code by pressing the run arrow rather than through a build/deploy, you can also click on the wires to probe what the values coming out of the joysticks are in real time. I’d recommend that as a debug measure.

Yes it can look like either an X or a diamond: it should look like an X when viewed from above, and a diamond when viewed from below.

Yours looks like a diamond when viewed from above.

Would you please post a link to the above-mentioned documentation. I would like to read it and maybe contact the author.



Check your USB hub and joysticks. We had a condition where you would enable the robot and it would start creeping on it’s own. It was a new condition that occurred without new code or changes to the drive chassis. Ultimately we swapped out the hub and were back up and running.