Honey, I bricked the RC

For the past few days, I have been prototyping all sorts of code. I used the crazy long serial cable to connect my laptop to the robot, and created a really long program/reset cable so I didn’t even have to leave my chair (true programmer style! :cool: ) Everything appeared to be fine. Then, a couple nights ago I crossed paths with the 8.2/8.3 volt bug. The robot put itself in auton intermittently. Power cycling did the trick. A few nights later, I worked on it for a couple of hours. I downloaded code fine at least 10 times. Then I put it in program mode, and tried to download the latest HEX file I compiled, and the RC wouldn’t take the file (I just kept getting the error “check to make sure the RC is in program mode”). I reset it and put it in program mode again, but I cannot say for sure that it was actually in program mode because the RC was across the field from me at the time (remember, I’ve got a cable that’s at least 20’ long…). I got up (out of my nice, warm, comfortable chair…:stuck_out_tongue: ) and checked the lights on the RC. What I saw baffled me: the “Battery Power” light was flashing green like normal, and the “Program State” light was solid orange, like in normal program mode, but the rest of the lights were off entirely. I went back and tried to load my HEX file again, and it would intermittently take it, but the OI and RC were no longer communicating, my code was not running, and I could not get any response out of resetting, power-cycling, re-sending code, etc. I am now entirely confused. I know I have discharged static through this controller more than once (yeah, I know, but it cannot be avoided when you rub the robot’s “feet” across the carpet all the time…), but I don’t think that’s what knocked it out. Now that I think about it, I didn’t have the presence of mind to test an old HEX file, but I will try that when I go back.

So as to keep working, I dropped our new '07 controller in the practice bot, and it’s working fine. However, I am a bit afraid for this new controller’s life. How do I know it won’t die like its older sibling (uh oh, I’m personifying the control system. That’s what you get when you mix FIRST and studying for an English final…:ahh: )? I made sure the old RC is doing the same thing without anything plugged into it. When nothing is connected but the + and -, it does the same thing.

Anyone else seen this? Is all hope lost? Did I truly brick a controller?

Thanks for reading that ridiculously long post,

I don’t know, call IFI.

One of our mentors was talking about sending it in. I guess I should call and figure it out.


Always check the IFI FAQs. Click here and scroll to the bottom. It’s not a common problem, per se, but it’s happened before.

We saw a similar problem with the 2004 RC controller we’ve been testing with recently. We were able to correct it by re-uploading the appropriate Master code to the RC. It did happen again today after we uploaded our code again, but uploading the Master code seemed to fix it again for the rest of the day.

I’m not sure what is causing it, but hopefully the same fix will work for you.

I have done this once or twice to RCs. I believe the way we got it out of this state was some combination of holding the reset and programming buttons to force the RC to some sort of “restore” state where it was able to accept code again. I do not remember the exact procedure, however.

Oh, oops. I didn’t even know IFI had an FAQ…oh how we are humbled…:o

For reference:

Thanks for pointing that out. I will attempt this when I go back either tomorrow or the day after.


With regard to the 8.2 volt bug, all of our ears would perk up if
the 8.2 volt bug resurfaced on the 2007 controller. We had it
persist on our 2006 controller inspite of applying all of the fixes.

With regard to your “bricking” the controller, there are software
failure modes that can hang the controller with the program light
lit, but it is not really in program mode and won’t upload a program.
Power cycling it does not help, as it comes back up in the locked
up state each time.
In this case, hold the program button down for four seconds,
none of the lights will change, and then try uploading the program.
It worked for us many times last season.


I will create a huge, conspicuous thread if the 8.2v bug appears on the new controller. I would guess it would, seeing as the controllers are identical AFAIK, unless it was a defect, but I don’t know for sure and haven’t seen it yet.

OK, I will try this if the official fix from IFI (see my above post) doesn’t work.

Thanks for your help,