How do you download a program and have it saved to the c-rio

I’ve Finished with the programming but i cant figure out how to save it to the crio. Can someone help?

Pages 13-14.

Ours will not deploy the new code we wrote. It will do the default code
if we reimage the cRIO.
Do we have to do it from a particular point.

We have followed page 13-14 over and over.

See the errors in this thread.

Thanks for any and all help.

Try an older computer. We are using an old computer with XP to do the downloading. At least one newer computer (also with XP) did not work and one Vista comptuer did not work either.

We had trouble with most of the flows on p13 and p14. We found that the one that worked for us was the numbered list at the top of p14. Follow it precisely. Don’t skip any steps. You will need your driver station and cRio both powered-on. It will work through the wireless if you have the wireless setup done right. (IP address set to 10.xx.yy.n) where xxyy is your team number. n depends on the device (driver station, router for driver station, wireless adapter, cRio). See control system setup.)

Our cRio boots itself after download.


We’ve had NUMEROUS issues with loading code, having every technical FIRST Official trying to help us at 8PM on practice night. Are you saying you can’t overwrite old code? We dealt with that all day yesterday, trying to overwrite a faulty autonomous. The solution was finally to switch to the advanced framework odly enough. These things may sound dumb, but make sure you are saving, building the new Real Time Application build (Which should only include robot main in the source files). Then try to Run as Startup, ignoring the error’s asking for you to disconnect, also you should be directly plugged into port 1 of the CRIO. If that doesn’t work, after trying run as startup, try Deploy.
We’ve been dealing with LabView idiocy for the past 48 hours, these are some things that have seemed to work for us.
P.S. did you install LabView update 3? Is absolutely everything up to date?
Also if you get a watchdog error, flash your CRIO and reupload your code. Hope some of this helps…

It is great to post the solutions to your problem, but I’m not sure all of the things you are combining together are really related.

If you have watchdog problems, the problem is almost certainly with the code feeding the watchdog and you shouldn’t need to reimage the cRIO. If all else fails and you aren’t in need of the extra safety provided by the watchdog, you can delete it from the code.

As for the deployment, something that we saw twice in DC were deployments where all sorts of source files were listed in the source page. That wasn’t the default build, and it can cause name collisions which will result in the wrong file being in memory at runtime. It took a long time to look at the Build Spec because we didn’t think it would have changed. Anyway, I know better now, and if you are having lots of deploy problems, it is probably worthwhile looking at, and perhaps deleting and building another. As you mention, it should have only the Robot Main VI included, let the LV linker do the rest. That and the additional exclusions page with the checkbox for libraries are the only things you should have to concern yourself with if you are using one of the frameworks. Also, another way to cleanup a controller is to ftp to it and delete stuff. You really shouldn’t need to reimage unless there is a patch or if things have been mangled by renegade file I/O or something really serious.

On the other hand, a reimage will not hurt, but is probably not necessary and will only make everything take longer.

Greg McKaskle

we had so many issues with this, I would make changes to invert the motors and they wouldn’t seem to deploy. After quite some frustration and alot of matches that didn’t go so well, I opted to format the cRIO which did the trick if we did it often

eventually I got everything working normally again

there has been alot of trouble with watchdog since the update as well, and even the boolean feedback nodes had some trouble.

the only way I seemed to get it to work was to
format the cRIO > make edits > Build > Deploy > hope it works

anyways, hopefully this issue is resolved soon

You don’t mention making that app the startup. As long as you’ve done this once, and use the same build name, I don’t think you need to do it each time, but then again I usually do it, and I’ve never seen a cRIO not run what I told it. So my only suggestion would be to do a Set as Startup after your deploy and see if that is possibly the reason.

Greg McKaskle

When I tried it at FLR it wouldn’t work no matter what I did, even deploying twice and such. I’ve done what you sugessted at least once, and running it in realtime gave me a “no code” on the driver station. Building and deploying is the only solution I could get working.

Any idea what the issue is? I even tried different Driver Stations And cRIOs
anyways the temp solution will work for now

Did you have a breakpoint set, or highlight execution turned on?

Just the norm

in the Project Explorer, there sould be 2 “Build Specifications”, one ABOVE the RT CompactRIO Target (10.xx.yy.2), and one BELOW. click the plus to the left of the “Build Specifications” BELOW RT CompactRIO Target (10.xx.yy.2), the right click the Real-Time App (or whatever is there like that), then click “Build”, wait for it to “Build”, then when that’s done, right click again and click “Run As Start-Up”. that should “download” the code to the cRIO. during the download proccess, you may get a box with errors, just click “ok” or whatever it says to let you continue, then LABVIEW will ask if you want to reboot the robot, tell it “yes” and wait. goto the Driver account, and have fun.

This thread is a year old. I think they’ve figured it out by now…:slight_smile: