How to configure limelights IP adress?

My team is trying to configure our new limelight 2+. We have the limelight finder and bonjour. When we first connected to the limelight without doing anything, it says the IP adress is 10.63.81.80. When we try to configure selected, it just leads us to a page that says “Hmm… can’t reach this page.”

We tried resetting it and power cycling it but it still came back with the same IP address and didn’t do anything.

Do you have any ideas?

Edit: we had to flash the firmware

What’s in the address bar of the browser when you get that error?

Do you have Windows Firewall enabled?

Any other firewall or VPN installed on your PC?

Do you have FRC Game Tools installed on the PC you were testing on?

What’s the IP address of the computer?

Can you ping 10.63.81.80?
Try opening up your web browser and go to 10.63.81.80:5801?
Re-Flash the firmware> Possibly corrupt flash?

Note: replace 10.TE.AM.11 with your team number, such as 10.18.95.11

Try using the limelight’s default page (http://limelight.local:5801) to connect to it. No matter how you configure your limelight’s IP settings that will always work to connect to it. Next, make sure your IP settings are set to Static IP, and the address is 10.TE.AM.11. The netmask needs to be 255.255.255.0, and the gateway needs to be 10.TE.AM.1. Make sure you update these settings and that they are saved to the machine. The IP that you give the RIO should be 10.TE.AM.2 . Power-cycle the robot and then you’re ready to continue.

A very important distinction to remember from here on is the port that you are using to connect to the limelight. The two that you will be using is port 5800 and port 5801 depending on what you are wanting to do. On port 5801 you can access the config panel (filtering and camera settings) and 5800 is just the camera stream (what you would access for smartdashboard). When connecting to the limelight, you need to use http:10.TE.AM.11:5801 for the config and http:10.TE.AM.11:5800 for the camera stream.

Keep in mind:
You must use http:// and not https://. The limelight isn’t broadcasting as a secure device, so if you try to connect with https://, you’ll get an error that you couldn’t establish a secure connection.
You must include the port that you are connecting with. If you just use 10.TE.AM.11 without a port, the computer might not connect to the thing you are wanting to, depending on what it uses as a default port.

Hi!
You may want to try and flash the new 2023 software they uploaded last night if you haven’t already.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.