How to connect to the cRIO

So this is my first year programming on the team and last year’s programmer didn’t really teach me what he did, so I’m trying to learn it all right now.

I finally got LabVIEW (with the FRC updates) good to go on my laptop and found all the Example codes. I disconnected everything from the cRIO we used last year and plugged it all into another cRIO (the new one is blank and never used). When I opened the cRIO imaging program though, it didn’t find any cRIO attached to the computer.
It has an ethernet connection and I tried turning the robot on (saw the lights on areas on so I know it isn’t a power issue). So why won’t my computer pick up the cRIO?

The first thing I’d do is to turn off the firewall settings. Once it sees the cRIO, be sure to change the computer IP so that you are on the same subnet as the cRIO before you begin imaging.

Greg McKaskle

Perhaps these links could help solve your problem:

firewall is already off, but can’t change the computer’s IP address. My teacher just informed me that you have to make a separate network system that you set the cRIO to and temporarily move your laptop to, rather than staying on the normal wifi network.

So now I’m trying to find how to set up the D-Link router and make our network system for this year (currently looking around on the site)


VERY HELPFUL! Thank you :slight_smile: following this right now

Following this link ( I’m still having the same issue. I have the cRIO attached to my laptop with an ethernet cable and changed the IP address on my computer to and but it still can’t detect the cRIO.

Im STILL having the issue on my laptop, however I plugged the ethernet cable into our white laptop and it worked perfectly fine. We’re not using it for competition because the screen is broken (connected to a separate monitor atm). I checked the ethernet properties and the IP address is:
10 . 37 . 53 . 5
and the Subnet mask is:
255 . 0 . 0 . 0

I set these exact settings on the same part of the wired internet settings on MY laptop (the one we’re using for competition) and it doesn’t connect.
I then tried changing the IP address on my laptop to
10 . 37 . 53 . 6
since the how-to says to change the last digit to 6. It gave me a pop-up asking if i wanted to allow or deny sharing with the newly found network! …and then still doesn’t find the cRIO.

What am I doing wrong???

If you haven’t done it already, turn off or disable the wifi and any other NICs except the one that the cRIO is on.

Greg McKaskle

I tried that but still couldn’t connect. However on the white laptop I could connect wired-ly to the cRIO even with the wifi still connected to the school network

Are you using a patch Ethernet or a crossover Ethernet? I had problems re-imaging the cRIO to come to the conclusion I had patch and needed crossover, worked fine after i swapped cables.

Most modern computers have auto sense, so there shouldn’t be a need to use a cross-over cable. On the other hand, if it has auto sense, both the cross-over and patch cable will work.

I was searching the NI forums, and there is a thread that indicates they saw this on certain computers and they are trying to identify common elements and a more reliable procedure.

The thread is here …

If that doesn’t seem to be the same as you are seeing, it may be good to start a report there.

Greg McKaskle

When you have the cRIO plugged into the computer that is working correctly can you tell what the IP address of the cRIO is? The imaging tool is probably the easiest way to tell what it is. When it is plugged in to the computer that doesn’t work are you able to ping the cRIO at the IP address you found it at on the computer that works?

I definitely try with a cross over cable (as was mentioned above).

The NI thread Greg mentioned was an issue we had early last season and was fixed in an update mid-season. I wouldn’t expect it to be an issue again this year.

If you don’t get it up and running by tomorrow give us a call at 866-511-6285 from 1-7pm CST

Tried a crossover converter and it didn’t change anything

Just did this and found out the cRIO’s IP Address is “”. When I pinged it on my laptop, I saw the attached results. So I CAN ping it. My laptop DOES see it. Why can’t the cRIO imaging program find it then?

A helpful friend from team 23 told me that the last digit of the IP address (the 2 bolded above) doesn’t really matter on my laptop as long as it isnt taken by something else, and to use the mask/subnet “” so that and “” are what I’m trying to connect with

If this isn’t solved by the end of school today I’ll definitely call (and post solutions here), thanks

EDIT: Also, the USER1 light is staying on too. Not entirely sure what that means but there’s more details

If it’s any help, you don’t need to reimage the cRio often (once is enough), after that deploying your code is all you need to do. (This is true for C++, I’m not sure about labview though)

As long as you have some way to reimage, and you know how to do it again if needed, you should be fine.

For a point of clarification, reimaging the crio is essentially wiping the flash storage completely, and reinstalling the OS. When you are programming, you copy your program onto the crio and it gets executed by the OS from the image you put on, you can replace your program all season without reimaging; the only reason to reimage is if you suspect corruption, or an updated image is released.

Did not know this! That’s much better actually :slight_smile: So then I just need to reimage it this one time and I should be fine

Now to look up how to change the code without reimaging the cRIO

All you need to change the code is to hit the run/deploy button on labview

Awesome, that’s much better of a situation

So now I just need to figure out why my laptop can PING the cRIO but not find it when I try to image it. I’ll test if LabVIEW can see it after school

as for the cRIO:

we never did figure out how to image the cRIO from my laptop but after several more hours of configurations, updates, etc, I finally imaged it successfully using our white clamshell.

I also successfully put LabVIEW code on the cRIO from my laptop, so everything is fine. When updates come out I’ll just use the white laptop. Thanks for all the help everyone

should the cRIO be imaged from the classmate or another laptop/PC?

Your development computer. For some teams that is the Classmate, for others it isn’t. The FRC Utilities update has the imaging tool in it.