How to enable netconsole?

I have posted this in the General Forum but there was no response. I figure I may get some here.

I have never used netconsole before. I have been using a serial cable. But netconsole sounds cool, so I want to try it. But I can’t get it to work. I FTP’d into the cRIO, found the ni-rt.ini file at the root folder as expected, added the “NetConsole.out;” at the beginning such as the line below.


EarlyStartupLibraries=NetConsole.out;vxfpsup.out;tsengine.out;

After rebooted the robot, I saw the COM console spitted out the following:


Loading LVRT...
* Loading EarlyStartupLibraries: NetConsole

So, it looks like it loaded the NetConsole server. After this, the COM console went quiet so it looks like all the output has been redirected from then on. But nothing showed up in the NetConsole client. The IP address box did not show anything. I even typed the robot’s IP address there but as soon as I hit enter, it cleared out and nothing happened. Is there a trick that I missed? I checked my laptop’s firewall and netconsole.exe is allowed to go through. Anything else I should check?

Thanks.

First of all, I commend you for making the switch to NetConsole. You will not be disappointed :stuck_out_tongue:

First, don’t hit enter when typing in the robot IP. Instead of the submit command that you would expect you are putting a newline into the IP. Just click into the console box for the IP to kick in.

Also, double-check your laptop is on a proper IP for robot comms (10.4.92.6 for you probably). Also make sure it is on the router.

I tried all that. I have put the IP address in the box without hitting enter. Although the IP address remained in the box, nothing happened. Also, the laptop has been my development platform for compiling and downloading code to the cRIO. So I am sure it has the correct IP address of 10.4.92.6. In fact, I set my router to assign me the .6 address whenever it sees my MAC. I will double check it tonight, but there is no reason to think otherwise. If I can download code to the robot, I should have perfect communication with it.

Try using NetConsole from the developer account on the Classmate. If it works, you probably did get the IP settings wrong on the dev laptop.

Also, try switching NetConsole.out and vxfspup.out in the EarlyStartupLibraries setting. Not sure if it would do anything but I think our’s is like that.

Also make sure NetConsole.out is in the ni-rt\system folder on the cRIO.

Yes, I checked. The file NetConsole.out is in ni-rt/system folder.
Hmm, I won’t have access for the Classmate PC for a while…
I will tried switching the ordering of EarlyStartupLibraries tonight.