How to get gradle to see changes to vendordeps files and update libraries?

Not using VSCode. Using both command line gradlew and IntelliJ IDEA.

The most recent version of the file “Phoenix-latest.json” brings us up to a newer version of the CTRE libraries than what we currently have.

What gradle task do we need to run to get it to pull and use the latest files? We’ve tried a bunch of commands (clean, build, downloadAll, downloadDepsPreemptively, etc) but none of them seem to actually fetch the latest libraries from the vendor.


How did you confirm this?

Some checks/steps…

  • If you look at build/tmp/expandArchives there should be several *-5.13.0-* zips.

  • Deleting the local “build” directory and running “gradlew build” may help

  • Create an VS example project. Then you can compare the files to your IntelliJ project folder. Even if you don’t plan on using VS, having it installed and in a state-of-readyness may be useful in the future.

Thanks for the reply.

I tried a few different ways.

  • gradlew dependencies which showed the versions still staying at com.ctre.phoenix:api-java:5.12.1 (which was our old version)
  • syncing and re-loading IDEA still showed 5.12.1 in the external libraries tree.

You’re right about the VS example…something we’ve been meaning to do. Also, yes…deleting the build dir would probably work as well…was just thinking there might be a more “normal” task or operation to try.

EDIT: Our procedure is to check the JSON file in the repo to see if has changed, copy it into our project and run “clean build”. For the most part, that should be all we need right?