How to program a bimba air cylinder in LabVIEW ~ pneumatic

So we have a bimba air cylinder which retracts out, and retracts in. Connected to our air thing, and connected to the pneumatic thing. How so do you go by programming the cylinder to make it work, retract out by a button, and retract in by a button?

I’d start by taking a look at the LabVIEW code samples for pneumatics, then post back here if you have more specific questions.

http://www.team358.org/files/programming/ControlSystem2015-2019/labview/index.php#SingleSolenoid

So regards to the pneumatics samples, would it be best to look at Compressor w/ cylinder or not?

Actually by simply opening a Solenoid, it automatically starts the compressor so you don’t need any compressor code unless you want to pause the compressor while the robot is enabled or get the status of the compressor in the code. Here is a walk through of the examples you need. How to code the Logitech joystick button in Labview?

You’ll need to know whether you have a single or double solenoid. There is a polymorphic selector in the open solenoid to pick that.

The compressor wired to the PCM should automatically be working when you open the solenoid in code. So you shouldn’t have to add that.

There are several ways to control. I often use a single button and just toggle it. For that you need a button toggle.

But for starters, you can code it so you have to hold the button to extend. Or better yet, use two buttons, one for extend and the other for retract. The second double solenoid example does this.

Well by the looks of snooping around, in this case its a double solenoid.

To each their own but I usually don’t recommend a toggle button in FRC because if the robot breaks or you can’t see the mechanism (robot facing the other way or behind something), it could make it much harder to figure out which state to robot is trying to go to. Holding a button or having 2 buttons is much better.

So if i wanted to take a snip and put it into LabVIEW, how do i possibly do that?

It’s better to actually do the programming yourself since you’ll learn more and be able to do more programming from what you learn but here’s how to get the snip into LabVIEW.

Hmm actually I just tried it and it’s not working when downloading the images from ChiefDelphi. I’ll do a bit of research…

Well on the example i got above from Team358, they have the Solenoid 0, and Solenoid 1, in that blue thing. How do i get one of those? Hence why i wanna get a snip put in.

Just drag the image right onto the LabVIEW block diagram. If that doesn’t work, right click the image and Save Image As… then drag the file from File Explorer onto the LabVIEW block diagram.
Note: I’m using Firefox as my web browser.

im using firefox also, but when i go to drop it doesnt work

Exactly what step is not working? How is it not working? Is Firefox updated?

Well i saved the image, but when i go to it, and try to drop it into LabVIEW, it doesnt work

Just to update this thread. I met RoboTigers7892 on Discord for a while and figured out some issues (more to go). But the LabVIEW snippets from Team358’s website are still not working for him. The only thing I can think of is because he’s on Windows 7 and it’s not compatible for some reason. Would someone with Windows 7 and updated Firefox be able to confirm this?

@Jonathan_L can you help me with the following questions:

  • The only snippets that do not work are from Team 358’s website?
  • If they create a snippet in their computer, can they use it?
  • We see the same behavior downloading the image to the desktop and dragging from the browser?

I am unsure the problem would be a Windows 7 + Firefox combination, but I wouldn’t discard it just yet, indeed.

Snippets from ChiefDelphi also do not work but that is the case for me too. I think ChiefDelphi is compressing the images and must be either deleting the embedded LabVIEW code or corrupting it. We did not try from other websites.

Good idea. @RoboTigers7892 Would you see if that works?

I don’t know if he tried dragging it directly from the website to LabVIEW. I watched him save it to the Downloads folder and then drag into LabVIEW. As he drags it onto the block diagram, the cursor becomes a not allowed symbol.

Does not surprise me either. We have the same problem in multiple websites. The compression takes away the LabVIEW’s metadata of the image.

I think moving forward it is a better idea to avoid snippets (to avoid confusing teams) and show the Label (Right click > Visible Items > Label) in all VIs of the screenshots, so teams can search them in the palette or using Quick Drop.

That make since for the time being. Let’s see, maybe discourse could automatically recognize VI snippets. LabVIEW Snippets not Working on New CD

1 Like