ifi_loader problem: run-time error '70'

Hello, I have been having a problem when attempting to select the .hex file to download in ifi_loader v.1.1.0. After I select ok, I get the following error:

Run-time error ‘70’: Permission denied

I am downloading a file from the bottom of the directory tree, so the path is less than 20 characters long.

The memory gauge in MPLAB shows that the file takes up less than 1/4 of the program memeory.

I am using a non-administrator account (school computer). I will be trying with an admin account tomorrow. If it works, though, I would like to avoid having to use it anyway as it would involve having a mentor log in every time I wanted to download to the robot.

Do you have any ideas what is causing this error, or what could be done to fix it?

I have tested on an admin account, and it works. Is there a way to avoid having to use an admin account, though?

Thank you,
Samuel Harrington

Team 931

I’m guessing Windows will not let you open the serial port device (COM1, COM2, or whatever) as a limited user (like most operating systems) - I’m not sure if there is a way around it. Try using a USB serial adapter if you have one.

I know how to get around it on Unix, but changing device permissions in Windows is beyond my experience…

Try modifying the permissions on the folder to Read/Write/Modify for the Users group.

Thank you Kingofl337, that works.

I think the problem was that ifi_loader keeps the path to the last ‘.hex’ file loaded in a text file in the install directory, instead of in the registry, and it crashes if it cannot write to it.

I had a similar problem with MPLAB, fixed the same way.

Many thanks,