Imaging Tool cannot open file or folder //NI MAX

Hi there, so we are having problems with our Rios, so when we try to deploy the code to the rio (The DS HAS comms with the rio) and it has an error saying it cannot deploy the code to the rio, we searched through this error and found out that a solution was to reformat and image the rio and we went on to try it but when we try to reformat it, we get this error:

Then we searched through this error and found out that the best option was to format it through the NI max and we also went on to install it, but when we searched on how to iinstall it we found out that there were many NI max versions depending on which NI hardware you are using. So how do Install the NI Max for the roborio.

Also if anyone has another solution for the previous errors I will be so thankfull. thank you so much

Are you trying to image a roboRIO 1 or a roboRIO 2?

I recommend following the steps here: FRC roboRIO Imaging or Firmware Update Failing

Its a rio 1

So we already tried those steps, we saw them in another topic in CD, but what we haven’t tried is the download the recovery.cfg into the rio, I will try that and I’ll let you know. Thank you so much