Importing NavX in Visual Studio Question


#1

Hey, I was trying to use some code from last year, but when I moved it to Visual Studio, I got this error:
image

I believe I’ve installed the NavX libraries correctly (I did it the same way I did the CTRE libraries, which are working fine):

image

All of the solutions I can find online are for Eclipse and I’m new to Visual Studio so any help would be appreciated. Thanks!


#2

Right click on your build.gradle, and one of the buttons should be Update project configurations. Click that and see if that helps.


#3

@Thad_House I’ve tried Update Project Configuration, deleting and re-installing navx_frc.json, the Java: Refresh command, and Java: Clean the Java language server workspace. None of them seemed to have any effect, though. :cry:


#4

Ok. In the bottom left of vscode, there is a JAVA DEPENDENCIES tree. Expand that entire tree, and post a pic. I need to see what’s in the external libraries part of the tree.


#5

Thanks so much for your help. Here are pictures of the Java Dependencies tree

image





#6

Ok, I think that’s something wrong with the json file you got from kauai. Where did you get it, did you use their installer? I wonder if somehow you got a beta version.

Can you replace the entire contents of the navx json file with what’s here.

https://www.kauailabs.com/dist/frc/2019/navx_frc.json


#7

It worked! Thanks again for your help!