Install/activate

Anyone else having problems activating the labview products? We are stuck in free trial mode until wefigure out what it does not like

Ensure you’re connected to the internet and that the serial number you are using is for the 2022 season.

Learn more: Find My FRC Team’s NI Serial Number to Activate Software

For further assistance, please provide more information on the error you are seeing, such as a screenshot (without the Serial Number).

Cheers!
Oscar

The my products page, we click on select action and activate. It opens the Activation Code Generation Form. We fill out the information where we can. The Select …actiate, Operating System, and Product Version boxes will not open the drop down menu. I have checked to make sure pop ups are not being blocked.

Interesting. Are you using the License Codes Generation tool because the computer you installed the software on does not have internet access or cannot connect to the NI servers? (sometimes schools have this restriction, hence why I ask). Are you getting an error in the NI License Manager when trying to activate it with the serial number through there?

Learn more: Activating NI Software Products

I tried the license codes tool (Activation Code Generation - NI) with Google Chrome (Version 97.0.4692.71, Windows 10, 64-bits) and it generated the codes properly. I wonder if you are using a different browser that is not populating the fields as it should.

Somehow, we were using the wrong serial number. It did activate most but there are 7 more products it did not activate. Thank you for your help.

One more question: in the past the LV homepage indicated FIRST 2021 or FRC 2021 the homepage now does not. Should we be concerned?

Did you install the 2022 game tools?

1 Like

Yes the game tools are installed.

1 Like

Did you install them after installing LabVIEW? The game tools are what install the environment that discusses FRC. If you aren’t see that, there was an issue with the installation, most likely the order.

I just installed this on our two computers the last two days, and I had issues because I didn’t uninstall the old versions. I would use the national instruments managers and delete last year’s frc game tools, then re open the new one from files. That may or may not help.

I just had the same thing happen.
It looks like the Game Tools installation did not work, no Rock Robotics.
The Game Tools installer thinks it’s all good.

Trying an uninstall and reinstall after a new download of the Tools.

That worked for me.
So, what I did was use Start->National Instruments->NI Package Manager
to remove the FRC Game Tools.
Then reran the Game Tools installer.

As an aside I also first tried the Repair action, but that didn’t help my case.

Make sure you have FRC LabVIEW Update checked when it asks: (it also originally asks about FRC Sockets, but in my case it was a redo and FRC Sockets was already installed, so this time the installer window didn’t ask about that again).
GameTools Install-1

The 2022 FRC LV Start Window looks like this:

I apologize for the delay in response, I decided to get sick for a few days. I will not be with the team again until Friday, but here are some things we noticed seemed to have happened.

  1. We have two versions of LV 2020 and 2022. Even though we have uninstalled all NI and reinstalled LV more than once.
  2. The game tools are installed and everything is activated on one of the laptops, but they seem to have updated the 2020 version.
    I only have one veteran programmer and no programming mentors, but the one student does not ever remember having 2 versions of LV installed. So this seems very wrong. We will go through the troubleshooting and suggestions you have given on Friday and hopefully we will be ready to catch up to the build team:)

When you get a chance, verify those things. (Also, please feel better)

LV 2022 doesn’t exist so there’s something being miscommunicated there.

In a typical install, I’d expect you to have LV 2020 SP1 from the 2022 LV Software for FRC installer. When you install the 2022 FRC Game Tools, I’d expect to see the window you see when opening LV discuss the 2022 FRC season. (It’ll still be the 2020 SP1 version. But it won’t be as obvious)

For the 2nd PC, do you see the last screen Mark posted? If so, it looks like you’re in a good state.

Thank you for all the help. The laptop I am on currently seems to have LV2022 up and running.


It still wants one more item activated, but I will work on that. .

Thank you Mark for the help. I think we have one computer ready.


I am still confused that our NI folder shows more than one LV

If you notice it has 2020 and 2021

The install just included a few additional help resources from the 2021 version of LV.
If you look at C:\Program Files (x86)\National Instruments you’ll see the folders for LabVIEW 2020 and LabVIEW 2021, but inside the 2020 folder will be the full LabVIEW while the 2021 folder just has a couple of actual files for the help service inside.

You shouldn’t need the Ethernet/IP Adapter Toolkit for the FRC download. I’m not sure where that came from. You can choose to ignore that license (or uninstall it from package manager if it bothers you).

It won’t stop you from programming your robot.