Installing VSCode WPILib extensions on Linux Manjaro(Gnome)

I am struggling with the installation of the WPILib extension on my laptop using Manjaro(Gnome). I’m pretty new in the Linux environment. One of the few things I learned is that Manjaro isn’t Debian based. Unfortunately the instruction on the WPILib website was only for Ubuntu https://docs.wpilib.org/en/latest/docs/getting-started/getting-started-frc-control-system/wpilib-setup.html.

I understood that the process was the same for every other debian based OS. I tried using the terminal to create the directories and move the folder to the directory. That’s where the problem started. I made my research and couldn’t find anything useful. I tried the --help command hoping that it would help but I didn’t really understood what the commands were meaning. I would love to learn how Linux work properly. I hope anyone has ever used Manjaro for programming in FRC and could help me in the process of getting my VSCode working on my Manjaro Laptop.

Most of those instructions should work fine, you’ll just need to download VSCode from the Arch Linux/Manjaro repositories using pacman. (and the last command won’t work but that only matters if you want to do simulation, though I’m sure you could find the equivalent package for Arch with a quick search)

https://wiki.archlinux.org/index.php/Visual_Studio_Code is probably the most helpful page if you’re having trouble with VSCode itself. The Arch Wiki is one of the best resources for Linux tools in my opinion, and even though you’re not on Arch itself, Manjaro is based on Arch so you will have almost all of the same packages.

1 Like

Outside of how to install VSCode, the rest of the steps are identical across pretty much any Linux Distribution.

As for how to install VSCode in Manjaro? In Linux, you generally use your Distribution’s Software Repositories through the included Package Manager or Software Center. For Arch based distros the package manager is usually pacman, and for Manjaro, there is a graphical Software Center front-end called pamac. You should be able to launch pamac from the start menu or run pacman from a bash terminal.

From the Arch Wiki page @aidangoettsch linked above, we can discover that Arch has a package in its repositories called code that is an Open Source Build of VSCode. I can tell you from first-hand experience that this package works great with WPILIB. Now we need to make sure that same package is available in Manjaro’s repositories (as I don’t know if Manjaro has all the same packages as Arch, though I’d suspect it does). Luckily, there is a web interface for Manjaro’s Application Repository @ https://discover.manjaro.org/applications/ and if I search for code or visual studio code, I find the code package. https://discover.manjaro.org/applications/code. I’d assume you could do the same from within pamac, but I don’t use Manjaro so I don’t know, but once you’ve found it there should be some kind of install button.

For Arch, I’d search it on the command line using pacman with pacman -Ss visual studio code or a similar search query. This also lists the code package, which is the build of VSCode I use. Then I’d install the package with sudo pacman -S code.

As I said at the beginning, the rest of the instructions on the WPILIB Guide should be accurate, with the exception of WPILIB having newer versions than shown in the images of course.

Good Luck!

2 Likes

Thank you very much for your help. I have successfully installed the open source VSCode using the Pacman package manager. Unfortunately I still got a problem with the set of command that are provided by the wpilib web to create the directory where the files extracted for the .zip folder downloaded on githup should go.https://github.com/wpilibsuite/allwpilib/releases. I have extracted the folder. The next step should be creating the directory, then moving the folder to it. That’s were the problem was really. This is what happens.

. Thank you again for your precious help.

Thank you so much for your help. I’ll sure use those resources for later trouble shooting.

Thank you so much for your help. I’ll sure use those resources for later trouble shooting.

You generally don’t want to blindly run commands that you don’t have a general understanding what they mean and are going to do. Just like with programming instructions, they are concise and won’t assume what you want. Look at what the instructions are saying to do, not blindly run the provided commands.

WHAT is the move command trying to do?

Drag the contents of WPILib_Linux-VERSIONUM directory to ~/wpilib/2020

What do you need to know to do this?

  1. Where is my WPILIB_Linux-VERSIONUM directory
  2. Where is ~/wpilib/2020

The second one is easy of course, you just created it with the make directory command mkdir -p ~/wpilib/2020

But the first? WHERE are you when you tried to move the contents of the WPILIB_Linux directory and WHERE is that directory? Do the two places line up?

1 Like

Thank so much it finally worked. I manually dragged the folder to the directory. I was able to complete the setup on my own. Now everything works just fine. Thanks again for your help.

Did you drag the WPILIB_Linux-VERSIONUM directory to the ~/wpilib/2020 directory or the contents of WPILIB_Linux-VERSIONUM to ~/wpilib/2020?

I dragged the directory to the ~/wpilib/2020 directory

Take a look back at the instruction. I don’t know if not quite following it will break anything, but I wouldn’t chance it.

your right, to be safe I dragged everything out of the WPILib_Linux-2020.3.2 directory and pointed the JDK in VSCode again. Everything seems to be alright.

1 Like

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.