Introducing Limelight 3

The models are working great!

We did have an issue where it kept complaining that no Coral was plugged in when we tried to switch a pipeline to “detector”, we had to power cycle a few times in a row to get it to work. Tried a few variations of plugging it in before and after powering up.

1 Like

@kreeve Sent a DM.

B2 is delayed because we decided to increase the dataset size by a factor of ~4! Also, B1 seems to be working very well for teams at the moment.


24 (4!) or 4? /s

Excited to see how teams use the ML models in season.

Can you share any details about how the limelight 3 factory calibration works? Are units individually calibrated? If so, what’s the test setup for that like?


Is there another batch that will be coming out?


I have been having issues working with one of my team’s new Limelight 3s. We have two on our robot, one is working well, detecting april tags normally the other is extremely blurry with no april tags being made out by the algorithm. I have tried all of the settings and tried cleaning the lens to no avail. This unit may have been dropped or hit something, I am unsure. I was wondering if there was a way to refocus the camera or if this symptom is indicative of another, deeper issue. Below are images attached of both the bad and good cameras. Any help would be appreciated.

My apologies if this post needs to be moved to a new thread, I am inexperienced here.


Thank you,


The poorly performing camera:

The normally performing camera:

1 Like

My limelight v1 looks like that and I can’t recall it being dropped, but yea I think the camera or wire going to it might be damaged…

That looks like the lens is out of focus - you could try moving it closer or farther from the camera to see if it makes a difference

@Robosquatch76 Yes, I should have an update on Monday.

@sckzor We will overnight a new one. Sent a DM.


We are running the newest OS on our limelight 3 (limelight 2 had the same issue) and when we see ID 5,the megapose suddenly moves into the driver station. As you can see from the image, the pose derived from 5 (the right green cylinder) and the simply derived botpose are both accurate, whereas the megapose is nowhere near them and it flickers around.

This only happens when ID 5 is being used, megapose works well with any combination of IDs 6,7, and 8. The problem only gets worse if we move farther from the targets. Any help is appreciated!


It happened with ID4 at the opposite end of the field for us. Does megapose require tags in the same plane and not offset back like these 2 are?

We are currently excluding tags 4 and 5 from the filter list until this gets fixed.

Google Coral is now supported by all Limelight models.

I believe so.

@Brandon_Hjelstrom FYI we’ve seen this behavior too, especially prevalent when doing hp load side autonomous modes.

1 Like

@Robosquatch76 Friday 11AM PT

@kdschmitz @icemannie @RyanShoff @Clayton_Yocom working on it!


@Brandon_Hjelstrom poke, and gl at 987’s upcoming orange county regional!

How does one utilize this? When I navigate to limelight.local:5800 does it default to h.264?

1 Like

FYI SeeedStudio is starting to accept backorders for Google Coral USB Accelerators. Available early May?

@Brandon_Hjelstrom bumping this.

Also wondering if there’s an ETA for the fix for this jitter

1 Like

Also interested in an ETA? We are seeing okay results with just the grid tags but a lot of wild results when we don’t disable the loading station tags. It seemed like 973 had things working at CVR at the loading station, but maybe that was just really good driving.

1 Like