Inventor 14 VBA Failed to Initialize

I just downloaded the Inventor Pro 14 student software off their educational site, and when I start up Inventor I’m greeted with the following message:

(Specifically I need to close the error 6 times, so I imagine that means it’s occurring 6 times.)
Except restarting helps nothing, and neither did installing. Help?

This might help:

When you say you go to run Inventor, do you mean you go to run the installer, or is it already installed and you go to run the actual program?

I can’t remember what the error said, but when I downloaded it I moved the installer .exe file to my desktop from my downloads folder. It wouldn’t let me install it because I moved it. I had to redownload it and try it again (moving the installer back to the downloads folder does not work).

I mean go to run inventor itself. I already installed the program.

Edit At the moment I simply downloaded Inventor 13 for use.

Do you have Microsoft Office installed and if so which version?
Have you tried to open the VBA editor in Microsoft Excel or Word?

I had some troubles installing Inventor 2014 but I think it was on my end, not theirs. As for running after the install it seems to work fine.

I had major problems installing Inventor 2014 (and 2013). It was caused by an improper .NET Framework 4.0. Factory resetting my computer worked like a charm :slight_smile:

I have not tried opening the VBA editor in Excel or Word

I haven’t had any issues running the installer. My issue is trying to run Inventor 14 itself.

My setup information:
OS: Windows 8
Processor: Intel Core i7-4770K @ 3.5GHz
System: 64-bit
Graphics: 2 MSI 7950s running CrossFire X
Memory: 16gb (8x2) Ripjaw X series
Autodesk Inventor Pro 2014 installed fine(?) both times, as well as repaired fine(?). I put ? after both fines because there were no prompted errors in these operations.

Bet you will get the same error if you try to open that.

And, er, how would I go about trying out this test?

I’ve had the same issue in the past. It was a new version of Microsoft Office that was the culprit. It seems to want to argue with Inventor. Something about how Office runs VBA in it’s own little environment or something like that. Look for VBA7.msi in your Inventor installation media (You may have to download it from Autodesk, but not follow through with installation again, because I think the default behavior after installing Inventor is to delete the installation files). Install that and Inventor should run fine (for now). I’ve heard opening an Office application will undo your progress and you’ll have to reinstall the VBA7.msi every time, but I can’t confirm that. Apparently it’s a known issue and Autodesk and Microsoft are working together on a solution. In the mean time, the customer loses. :frowning:

Good luck

Yeap that’s the exact issue I linked earlier.
Just be glad you didn’t get French for a spell checker (not kidding that was an actual Office bug).

To start VBA in Microsoft Word or Excel:
Open either program.
Press these keys at the same time: ALT F11

Bet you get an error instead of the VBA editor.

Well for Microsoft Office University 2013 Word I got what appeared to be a VBA editor rather than an error.

Guess I lost that bet :wink:
Interesting that it works at all.
Probably have the older version.

As pointed out above try to search for your VBA7.msi file.
Run that.

I ran into the same exact problem. I’ve been using Solidworks and Creo while I wait on a solution from Autodesk/Microsoft.

What version of Office are you running?

This issue extends (just a little bit) to SolidWorks as well (and rather annoyingly). In order for SolidWorks to open Inventor files, it requires Inventor to be installed (or possibly just the reader), but in any case, if you have the issue with Inventor, you cannot open up ipt files in SolidWorks either. This is rather annoying if FIRST releases game elements in Inventor files (like they have in the past). Fortunately, many files also have STEP versions available.


Generally I just wait for the STEP files to come out. I know the conversions are not perfect but I have no problem going in and fixing the important parts if need be. I haven’t been using any FIRST published files lately, mostly been designing dream robots for Ultimate Ascent :slight_smile: also has a ton of solidworks files for FIRST

I was able to install Inventor 2014 in a VMWare Workstation 9 virtual machine with Windows 7 Home Premium 32bit and .NET Framework 4.5 full administrative download.

It starts fine like this.
Will try installing Office 2013 over it later.

It put Vba7.msi in:

By any chance are any of the affected people using the 64bit version of Microsoft Office?

Maybe what you need is a less powerful computer.:smiley: