Inventor:Disappearing grid and drawing

Alright, a teacher I know has a laptop (WinXP Pro on it, very new) with Inventor. In sketch mode, you can’t dimension without a ‘void’ of sorts covering the dimension value and the drawing. You can move the dimension as far away from the object as you want, the object can be seen but the ‘void’ still exists. Also, if you leave the dimension there, and do a 3d rotate, you can find the drawing on the other side of this ‘void’ if you previously covered it with the ‘void.’ You could call it a curtain.

I know there was at least one thread that described a similar problem, but no real solution as far as I saw. Any solutions would be greatly appreciated. Thanks.


That sounds like a redraw issue with the laptop’s video card. The best thing to check is to make certain the drivers are up to date, but that doesn’t always fix problems.

Unforunately, laptop video cards aren’t kept as current as desktop models and finding new drivers is sometimes difficult.

I agree with MK - it sounds like a graphics adapter problem, or possibly insufficient system memory (but probably the GA). First see if the laptop’s adapter is 128-bit and OpenGL. Next check Autodesk’s Hardware Requirements. Note that a number of conflicts are posted for Inventor 10, including Google’s Desktop Search. You will probably find that Inventor will be less problematic if you have no other applications loaded while it is running. That includes IM. Especially IM - even if it doesn’t interfere with the application, it distracts the user! :wink:

What version of Inventor is being used?

I agree, too. Things not drawing consistanly is usually a hardware problem or lack there of. If something else is running on an otherwise OK card, then that program might be taxing your hardware too much for Inventor to work right. Try cutting down of whatever else is running.

Inventor 7 is being used.

Other than that, I upgraded the graphics driver for the teacher’s laptop with no luck on fixing it. (The chipset is of the Mobile Intel 915GM/GMS.910GML Express Family.) So, I’ll take the explanation that it could be the hardware. I’ll also try and run it with fewer other programs running.

Thanks for the suggestions.


Have you checked to see if the latest Inventor service pack has been applied?

Double check all the variable settings under dimension. You may have set a very large box for dimension text but have selected a small font. There also might be a setting for “gap” which is the amount of white space between the end of the dimension extension line and any other dimension element. Unusual settings in these areas give very strange resuts. Also check that the color of all your dimension variables. You may have one set to the same color as the background in which case it is there but you can’t see it. A check I use with Autocad in such cases is to erase with a crossing box where there is no drawn elements. If the program returns that it found something, then there is an object that is the same color as the background or it is extremely small (or large).

When I tried Inventor 5 on a celeron 700 with built in graphics and 256mb RAM it all worked fine except the dimensions would not show up. I upgraded to a P4 2.4 with Geforce FX 128mb graphics card and 512mb RAM and Inventor 5 and 8 both run beautifully.

I’m guessing you need a better graphics card.