Inventor ignores Windows DPI settings?

I just got myself a beautiful new Dell XPS 13 with a nice 3200x1800 touchscreen display. Of course, that resolution at 13.3" requires DPI scaling to be even remotely usable, which I have at 175% (OS is Windows 10). However, Inventor seems to ignore that for some UI elements, resulting in unreadably small text.

Every other UI element in Windows seems to be fine.

Make sure the highlighted box in the program properties is unchecked.





That looked like it, but alas the box was already unchecked :frowning:

I’m in a similar situation with my Surface Book and Inventor. I ended up running my machine in 1080p resolution to get things to work. Definitely a pain.

For travelling I recently purchased a Microsoft Surface Pro 4. I was aware of the issues around some text and dialog boxes not displaying properly.

I am continuing to seek a better solution, but have had to resort to Magnifier and a few other tricks when creating videos.

Not really sure if the same problem occurs with Inventor, but for SolidWorks, large screen resolutions make everything smaller, since icon sizes are (for some reason) based on pixels rather than screen ratios (supposedly getting fixed in next version). And no matter what settings are changed, very little can fix it.

Here are some Autodesk Forum links that may help a bit.
http://forums.autodesk.com/t5/inventor-general-discussion/high-resolution-displays/td-p/5114436

https://forums.autodesk.com/t5/inventor-general-discussion/screen-resolution-of-3d-window-on-high-resolution-laptop-screens/td-p/5279929

I have a display with the same resolution on my Lenovo Yoga Pro 3, and these problems have plagued me for a while.

One solution I have found is injecting a custom DLL that forces it to ignore the DPI and actually look nice, it’s called DPIMangler (on mobile, don’t have a link, sorry.) Their site has instructions on how to inject it, and it has worked for me in several programs.

Good luck!