Inventor quits on Me!

I’m having a huge problem:Inventor (Ver5) used to work on my pc no problem but ever since I Installed Inventor 7 it would work and after a few days e.g 3 or 4 it comes up wit an error message.First it was a memory error,I reinstalled windows and thats all that works but please does any one know a way to fix it thats easier!I can go into inventor but as soon as i create a new part windows says it has encountered a problem with inventor and I have to exit.Please any help would help!

what are ur system specs?

Hey No my specs arent the problem it works well and then come’s up with the prob.Any way I’m running a 1.3Gz Duron,648Ram,128 Mb GeForce Fx and believe me I’m sure Its software Prob!I just cant put my finger on it!

This sounds like a video driver issue to me. I experienced the same thing (on a different video card) and updating the drivers solved it.


Might want to add some RAM into your computer as well. Its not very expensive, and will really make your computer work faster. Also if you are on XP, it takes up a lot of RAM itself, so you may not be running other applications at 128, which would put your computer under the mimimun requirements to run Inventor.

We get lots of protection faults with Inventor, especially when we get a complex assembly with lots ‘o’ constraints. We’ve had the same problem on lots of computers with very different configurations. Save Often is the manta. Inventor is cool, but I can’t believe that industry will put up with that.


To be fair, “industry” tends to use different hardware then we do. I believe that most of the crashes experienced with CAD programs tend to be hardware/driver issues and not the fault of the software producer.

The size of an assembly in RAM should not be a problem until you get into very very large assemblys. I’ve had assemblys with 1600 unique parts open and, although it didnt run smoothy, I did not experience any crashes. Of course this was with solidworks, I’m not sure how memory efficient Inventor is.

We are kindof forced to use Inventor, but Solidworks tends to crash half as often as Inventor for me (and is used a lot more in industry).

The measure distance tool on large assemblies sometimes crashes Inventor 5 for me.

If you haven’t already, Install Inventor 7 Service Pack 1 . It’s worth a try …

Hey No u misunderstood me I’ve got 648mb ram,and 128 video ram It is a software problem no questiones asked since it works fine when windows is reinstalled and this is the second video card its works but this error acurs always when i add software to my pc.I tried fiddling with msconfig so that windows dont load any junk @ startup but that also doesnt seem to work!

This patch doesnt work I have inventor 7 professional and that patch doesnt patch it says “Product not installed” Cmon It is installed!And Yes I do have the locked patch for the unregistered version.Yes my copy is legal I have the box they sent it to me Its just this error is getting so repetitive!NEED HELP!