IR Board Problem

We are trying to train our IR board. We connected it to the power and hooked everything up. When we turn it on, the error light flashes for a second and turns off. After that, pushing the little button achieves nothing. Every time we turn the power on, the same thing happens. Can anyone tell us what the problem is and how we can solve/fix it?

Read Update 10

I believe you have the same problems that we just discovered today. Our board worked fine until this evening right before we head to a final mini regional :frowning:

We have the same symptoms that update 10 explains.

Hope you have better luck.

Thing is, this is the first time we’ve plugged in the board (to my knowledge). So maybe it was already corrupted when we got it?

Unfortunately there were reports earlier of IR boards not working out of the box too :frowning:

refer to this thread, which solves the problem

We discovered the same problem last night after we got back from our mini regional practice competition :eek:

I guess this is what happened to our IR board at first. It corrupted itself. Now I worry about our new one, even if we do add a switch, I don’t know if that will help. Our robot pulls so many AMPs that it often goes below 5V while running, which could cause it to corrupt. I wonder if a large, in-line capacitor, before the switch for the IR board, isolated from the rest of the power system with diodes, will solve this problem.

Also, does anyone know where to get the code that the update was talking about? They mention it, but there is no link, and I cannot find it under the competition manual or IFI.

Thanks for the help… Now to figure out the ICSP programmer stuff…

Does anyone know where to get an ICSP programmer or how to make one? We’d like to figure this out before ship day so we can see if this is going to work.

We have had our IR board quit as well. Our board had the voltage regulator removed and bypassed and was powered from the 5 volt rail where signals from it were connected. It was working when it was hooked up yesterday, but we power cycled the robot a number of times last night during testing. There were no wiring adjustments so we are sure it was not miss-wired since the last time it worked. When we came in this morning, after patching in an in-line power switch first that was suggested in the team update, and the IR board was not responding. If we put it in learn state it goes through the learn sequence until you get to the fourth light and then it freezes during the second check on the fourth light.


hey, you might wanna purchase / find someone who has
an ICD2 programmer, or a PICKIT2 package

their’e great!

We had success with it today as well. I used winpic to program the chip with a custom serial cable I made late last night based upon a whole lot of googling and research. I too erased before programming to get it to work. For teams in need of doing this that don’t have fancy PIC programming hardware or time to order some, attached is the harness schematic I made. I used a PC serial port (and not a laptop) because most of what I read said that the laptop voltage levels are not high enough on the serial port to program it.

Best of luck to everyone. **NOTE **- I take no responsibility if it does not work for you, damages your IR board further or the PC you use to program it. I can promise it worked flawlessly for me. Just in case, I would not have the IR board connected to your main robot controller while programming the board; in the event there is a problem, it won’t hurt your robot.

IR Board Reprogram (34.4 KB)

IR Board Reprogram (34.4 KB)

Also, if I may make a recommendation… we are now using a Spike to turn the IR board on and off. Whenever the robot is in autonomous mode, it turns on, and when autonomous is off, it turns off. It’s a little more complicated than a switch, but I think it is a little smarter of an idea, since you don’t have to remember to turn it on and off, and it serves the same purpose.

I have a pretty detailed post here about that. :slight_smile:

Man… beat again at a good idea!

Thanks! Ours went down last night and I cannot find a pic programer. I will give this a try.

So I did this, I was able to initialize (once I used a desktop, not a laptop) and I was able to erase the program currently on there. But when I go to load the FIRSTIR.hex, it gives me an error saying there is a problem with the file. If I ignore that fact and try to load it onto the PIC then it goes through and fails during verification. Any ideas? I’m using the FIRSTIR.hex posted here. Is it possible something is wrong with that file? Or am I doing something wrong? Thanks.

Humm, sorry to hear that. Did you unzip the hex file? :yikes:

I didn’t have any problems and I used the same file you mentioned. Can you read from the device without error? I wonder if your PC serial port voltage is too low, I saw mention that that could cause problems when I was researching. I guess since it worked for me, I don’t have much insight into figuring out what can go wrong.

Yes I unzipped the hex file. I can read from the device without error (although now its empty!). I don’t think the serial port voltage is too low, it erased the device fine. As soon as I open the hex file (before loading it into the device) I get the following error:

LoadHex: Ignored 316 locations at addr 0x000400...0x002008 .

Also though, do I need to manually select the device (PIC1687)? Is anything to be changed in Device config? When I select the device that it says:

Couldn't find "devices\", please borrow/copy from MPLAB !