IR Board Problem

what programmer are you using? (ICD2?)
what software do you use with it?

Check out the screen shot in my powerpoint slides. Under the interface tab I selected “JDM (2) for serial port” under Interface Type, and then I loaded the ElCheapo_PCB.ini for the definition file. This was via trial and error before I got “success”. Maybe that will help if you didn’t do that.

I’m using iambujo’s method of a serial dongle connected to the board.

Yes, I saw that and set both of them. Maybe I’ll try again on a different computer. Thanks for your help. Its strange because I can connect, erase, read, verify, etc. I just cannot write the hex file. Perhaps it is the voltage levels.

The IR PIC hex file has also been posted by FIRST on their Additional Technical resources page

To anyone with IR board problems that’s coming to the oregon regional, team 2273 (shameless plug) will graciously give you a hand in getting it to work. It’d be a shame for any teams to not get their robot to do at least SOMETHING in hybrid. We have a PicKit2 and the know-how to get your boards up and running.

Thanks. The files are identical. So that’s not the problem.

I’ll keep fiddling with it and post if I have any success…

i have the same problem as DarkJedi613
No luck so far.

I got it to work!

The things I changed (note I don’t know if all these are necessary):

Devices Tab:
Choose PIC16F87

Options Tab:
Provided the MPLAB devices directory (you really only need one file - “” and it was asking for a 16F716 algorithm, but also providing PIC16F716 didnt help).

Interface type: JDM (2) for serial port
Custom interface definition file: ElCheapo_PCB.ini

And that was it! Note: it gave me LOTS of errors, but the device works now (through test it with a remote) so I’m not sure whats up with that. I just tried it again on my laptop (through a USB to serial adaptor – I changed the Option “I/O Port Access Driver” to “no direct access at all, only use win API”). This DID NOT work however – I could not even erase the board. It is possible a true serial port would work however. Good luck!