Is there a way to unbrick a Spark Max?

Our story so far……

After much consternation, our programmer got the process right, and was in the process of upgrading the firmware. She was watching the download progress, when her laptop battery died.

After plugging in the laptop, there were no lights. No ability to connect. No response. It appears to be bricked. Is there a factory reset procedure?

(Fortunately, we do have a spare, but we will need that one to come back from the dead somehow in the near future.)

To recover from a bad firmware you can do the following:

  1. With the SPARK MAX completely powered off, hold the mode button down
  2. Plug in the USB with the mode button held down
  3. Release the mode button once plugged in, the LED will still be off, but the computer should be able to recognize the device
  4. Flash the firmware using the SPARK MAX GUI as normal (The GUI itself does not need to be connected for this part)
4 Likes

Thanks. Will give that a try next time we’re in the lab. (Right now we are officially locked out due to polar vortex.)

We seem to be having a similar problem with one of our 5 spark max devices. Windows does not seem to recognize the device initially. If we hold down the mode button and plug in the USB we see the device at this point in windows identified with STM32 BOOTLOADER but are still getting connection failed with the spark max client and unable to flash any firmware. We had no problems with the other 4 Spark Max devices. Any ideas or other troubleshooting we should perform?

@Macfraser This is a video that shows the steps mentioned above Please note you don’t need to be connected in the client to flash the firmware from recovery mode.

@Greg_Needel thanks for the quick response and the video, We tried the steps outlined in the video but continue to get the message after clicking continue

Error loading firmware. Please disconnect the SPARK MAX controller, and try again.

Any additional thoughts?
Thanks

This is a dumb one but try a different USB cable. If that doesn’t work, please send us an email to [email protected] and we can help you farther.

Thanks gave it a shot and that didn’t work. Will send a note to support.

Thanks

If you go to the Windows Device Manager, after you plug in the device while holding the mode button you should see ‘STM Device in DFU Mode’

Unfortunately I still see it only as STM32 BOOTLOADER When the mode button is not down it Windows indicates that the device is not recognized, when the mode button is held down I see STM32 BOOTLOADER under Other devices.

We switched to a different machine (windows 7) and got it working (our other machine is a windows 10 - not sure if that makes a difference).

Thx

Yeah that sounds like a driver issue, not sure why the driver did not install correctly. Glad you got it working!

For others searching this topic, the driver on Windows 10 should automatically be installed, and is also included with the installer for the SPARK MAX Client. The good news if you have this issue is that the device firmware is definitely recoverable.

We do have obe computer (which also coincidentally runs win10) that never recognises devices. In device manager, they all show up correctly, but it never actually connects. Our other win10 computers and win7 one seem to connect fine. I tried to troubleshoot for a while to no avail, so moved on. It is odd though.

We have had a similar problem - with a mix of six Windows 7 and Windows 10 laptops. Currently only one laptop (Windows 10) recognizes the hardware and works with the SPARK MAX Client. The correct drivers load on some and not others. I’m hoping nothing happens to our magic laptop this season :slight_smile:

@Will_Toth Do you have a location on the REV site where the driver can be downloaded for those teams having problems ? I know you said it is in the install package - but can you link to it separately?

1 Like

Here are the drivers for Windows, we’ll post them on our site as well.

https://www.revrobotics.com/content/sw/max/firmware/SPARK-MAX-FirmwareUpdateDrivers-Windows.zip