Is this normal?

This is kind of hard to explain but is it normal to have to cycle the power on the robot and/or the Wireless N game adapter several times before communication will be established between the cRIO and the Drivers Station? This is not a new “problem” for us as it has existed since we first got our electronics in December. EVERY time we start up the robot we have to either cycle the power or pull the plug on the wireless N game adapter to get things communicating. Most of the time two or three cycles of just the game adapter does the trick but sometimes we have to shut off the main breaker and count to 10 before powering it back up. Early on it was irritating. Now it is just plain frustrating because it takes quite a bit of time and effort to get the robot/cRIO and the Driver Station talking. Once everything starts talking it is fine until you power off and back on again. I just can’t imagine that this is normal. If it is then there will be a lot of wasted time trying to get the robots communicating with the field at the beginning of each match. I’m not talking about the boot up delay either. With our system you could wait an hour and it won’t start talking unless you cycle the power just right, hold your breath and have all of the freshman jumping on their left foot facing North. :stuck_out_tongue:

Are other teams having these sort of issues? Anyone know what we should try?

Have you been running new batteries every time you test the robot?

In a chat with 103 (beta testers) a few days ago we discussed how random loss of communication is possible if the battery is low on voltage. Although the battery is able to sustain robot functions, the wireless components are the first to reset with a low battery. I know it sounds too simple but try with batteries that are fully charged each time and let us know the result.

Make sure that you’re using the dedicated 12V output from the PD instead of any of the WAGO output pairs with a 20A breaker.

There is a dedicated “boost-ish” supply on the PD for providing stable power to the wireless adapter. If you’re using a WAGO output pair with a 20A breaker, you’re not wired per the diagram and you’re not getting the benefit of the “boost-ish” supply.

Russ

Yes, it does it with fully charged batteries fresh off the charger. Once communication is established everything is fine so it isn’t the battery.

Akash, I’m sure Eric will be around with more detail, but if things are properly wired I don’t really see how this is true.

Both the 24V supply for the cRIO and the 12V supply for the Gaming Adapter are listed as operational down to 4.5V input in the Datasheet.

The Digital Sidecar requires at least 5.5V to run it’s 5V supply and 6.7V to run the 6V servo supply. The Analog Breakout requires 6V for normal operation.

Yep, wired properly as well. It is like the “boost-ish” supply isn’t doing something right I guess.

What we’ve noticed is that it might take 30 seconds for communications to be connected and displayed on the DS. It takes the cRio that long to powerup, boot and run the program. By cycling power you have to restart the cRio. If you are turning off the bridge several times, while leaving the cRio on, you might not be waiting long enough for the cRio to boot.

Just going by past experience and talks with a beta testing team.

That’s what I meant by you can wait an hour and if it ain’t going to talk it ain’t gonna. We boot up the Dirvers Station first then the robot. Then we all watch the three little green lights on the gaming adapter like we are watching lottery numbers being drawn on TV. Then after a minute or two we try unplugging the power connector on the gaming adapter and replugging it in. If by the third time that doesn’t work we just turn the whole robot off, count to 10, turn it back on and start the whole process over. I suspect either something is wrong with the power distribution board or the gaming adapter but I not sure which. The power distribution board is $190 and the gaming adapter is $100 (at our closest Best Buy). Anyone have an educated guess as to which one to try first? At least noone has come back and said that this is normal so I guess we have a problem somewhere. :frowning:

can you check the power “flavor” with a multimeter? I would make sure the power board is sending out what it should. If it is, go for the network adapter. If not, I’d buy a new board.

If that’s not possible, is there a way you can get with another local team and swap out adapters?

How about using the wall wart that came with the wireless adapter and seeing if you get the same periodic comm failures? It’s obviously not very mobile but at least gives you another data point.

If you decide to check the power supply output voltage, you’ll want to be careful with interpreting noise. When the battery is > 12V, battery voltage will be passed almost directly to the adapter. When the battery is < about 8V, the boost converter will do a decent job of producing a smooth 12V output.

When the battery is between 8 and 12V, the output will have a bit more noise than you might be expecting. In this region, the boost converter cannot operate very efficiently. The input stage on the wireless adapter, however, has been shown to be very tolerant to this 1 or 2V pk-to-pk ripple.

When the wireless adapter browns out (ie it’s input power supply voltage goes below about 5V which is WELL below the output noise on the “boost-ish” supply), we have seen them lock up and require a hard reboot to recover. This is why I was suspicious about whether you were using the intended output on the PD.

Without seeing your setup, I’m suspecting that the “boost-ish” supply in the PD isn’t functioning as intended. If you’ve got a multimeter and a bench supply, measure the supply’s output while varying the PD’s input. You should see the converter working to maintain a constant 12V supply. Also, does the PD whine (typically due to the wireless adapter’s 12V boost-ish supply but also a little due to the 24V cRIO boost converter)?

Russ

I need a few more pieces of information:

What are the adaptors LEDs doing when it is not working?

What is the voltage it is getting when it is not working?

Next time it stops working, record those and post. Then, pull the plug out of the adapter and plug it back in. Wait ~15 seconds. Does it work?

If it does, it is a problem with your adapter. I alerted Linksys to a problem a few months ago. If the power glitches OR takes too long to ramp up, it will hang indefinitely.

I spent a long time characterizing this, and I’ve only managed to get it to happen by

  • using an unregulated battery connection
  • “fuzzing” the supply down below 3V.
  • unplugging and replugging the connector very quickly
  • ramping the voltage very slowly.

Basically, one of their processors hangs, and there is no watchdog to reboot it (ALWAYS USE A WATCHDOG). So, if you ever have a power glitch at home and your Linksys product goes out to lunch, blame the lack of a watchdog.

Vikes - Thanks for the faith :wink:

Akash - The cRIO and the WiFi are the last to die. Motor control is cut several volts before the logic system dies.

Meaning we need to figure out what the heck is going on with our bot then. Random loss of communication is not good. But for us it only happens on a low battery. Any suggestions Eric? Thanks.

Not without more information.

Some of the 2008 batteries are bad, their voltage will drop while loaded rather spectacularly.

Everything is wired to its correct port? Some teams have tried running the adapter off of the camera port.

Ok, we just ran some tests using the advice posted above and here is what we came up with.

First per Russ’s suggestions we tried it with the wall-wart that came with the gaming adapter. The gaming adapter was powered up first and then the robot was powered up. The results were the same as usual. No Comms. We waited more than 5 minutes.

Unfortunately I don’t have a variable power supply capable of delivering enough amps for the whole system. I do have a 13.8VDC 100Amp power supply used for car audio system testing. With it connected as a replacement for the battery we observed ~13.5VDC on the output of the PD board for the gaming adapter. With a battery we got a similar 0.3VDC drop (battery 12.8V and output ~12.5V).

I think the PD board is fine. Onto testing the gaming adapter using Eric’s suggestions:

POWER = (either) Solid Orange (or) Solid Green
ETHERNET = Solid Green
WIRELESS = Off
SECURITY = Off

See above. About 0.3V less than the voltage input to the PD board.

Yes, that is what we have been doing except we usually haven’t been waiting 15 seconds before powering it back up. We have been unplugging and plugging it back in multiple times but waiting less than 15 seconds before plugging it back in each time. If it didn’t start working on the 3 or 4th time we would cycle the whole system off, count to 10, and then restart. That would usually work. We must learn a little more patience I guess.

Seems like we have a bad gaming adapter. We will get another one and try it out. Hopefully that is the problem since the gaming adapters are half the cost of a PD board and MUCH easier to replace.

Thanks for everyone’s help. We will post how it turns out after we get a new game adapter.

This only confirms the issue if “unplug (at the adapter), wait 15 seconds, replug, wait 15 seconds” fixes it every time. If it doesn’t, I don’t know what is going on.

I’ll have to check tomorrow, but I believe that LED arrangement means “locked processor” in the adapter.

I’m hesitant to say that a new adapter will fix all your problems. Are you positive it isn’t configuration?

It pretty much always “hangs up” the first time you try to start it after it has been off for any significant length of time. Unplugging it, waiting 15 seconds, and replugging it in seem to work so far every time. After is is up an talking then things seem to be fine. It just doens’t want to start talking. Once it is up and talking you can cycle the main breaker off and if you turn it back on reasonably quickly (seconds not minutes) it will connect without a problem. Basically if the robot has been off for more than a minute or so you have to unplug the power cable from the game adapter, wait ~15 seconds, then replug it up to get it to start talking again.

It is configured per the instructions as far as I know. How could we configure it improperly and it work after we unplug, wait 15 seconds, and then replug? I’ll be happy to check, just don’t know what to check for. Could you be more specific?

I’ll head to Best Buy and get another one as soon as I can this week and hopefully that will solve the problem.

It is the most logical explanation, I’m just always hesitant to tell a team to go spend money. Consider my last post as me grasping at straws in an attempt to save you a few bucks.

Hopefully someone else will step in with a brilliant fix. Otherwise, I think you know what has to be done.

Trust me Eric, I will be very happy if a bad game adapter is all that the problem is. It is two quick connections and a bit of Velcro to replace. It will literally take longer to resetup the network settings than to replace the hardware. I will happily spend $100 if we don’t have to replace the $190 power distribution board and redo a bunch of wiring. Given the quirkiness of wireless networks we at first just thought it must be part of the bugs yet to be worked out in the new control system. By this time we could no longer imagine that all teams were going through this and that it was normal. If a new game adapter doesn’t solve the problem I will be sure to post it here and we can continue to explore other possibilities. For now my fingers are crossed! :slight_smile:

I believe I remember at least one person getting a bad bridge, and getting it replaced through Linksys.

If you don’t have an early regional, it shouldn’t be too late to go through Linksys tech support.