Issue with Installing WPILib and building template Java project

Hello, I am trying to install WPILib on MacOS 10.15 and I went through the process, installed all the extensions in the right order and ran
Set VS Code Java Home to FRC Home

but in trying to build the template program for an arcade drive in java I get the following build error. From a quick read through I can see that it is trying to pull resources but cannot find them. I do not see any prompts in the security tab indicating that my computer could be blocking anything. How can I resolve this issue?

I’m not sure if this is the problem, but this might be related to the problem you’re having: or

At first glance it looked like your computer wasn’t connected to the internet, but I think the error you’re getting indicates something going wrong with signed certificates.

Maybe a WPI dev can comment here if this is the problem or provide other suggestions.

I just checked the server and the certificate is valid. Are you able to go to in a web browser? Is your clock set correctly? Could someone be attempting to perform a man in the middle attack on you?

I am able to go to that website, my clock is automatically sent and I certainly hope that nobody is attempting a man in the middle attack on me (though I think that is very unlikely). What else could I check?

Have you tried rebooting? It could be that VS Code is still picking up another version of Java.

(For context, the server requires Java 8+ security features)

I have tried rebooting, I believe the error is the VS Code isn’t recognizing the Java that came with the WPILib folder or any Java for that matter, though running a Java check command terminal confirms that I have Java version “1.8.0_25”. As for the security features, is there something on my end I could check to meet those requirements?

I don’t have that version of Java to test with but 8u25 is very old and is probably the issue. I’m not sure why VS Code isn’t using the version of Java included in the .tar.gz download. How are you building the robot code? With the outdated java version installed I imagine it wouldn’t work from command line and only work from the VS Code menus.

I am using the in built VS Code menu (through Cmd+Shift+P) to build. I can try and update my version of java and see if that helps.

That appears to be the solution, updating my Java version on my computer appeared to have solved the problem, though I don’t think VS Code is using the version that came with the download. I am running Java 13 now and it appears to have worked. Thank you

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.