Issues Connecting to Limelight after Flashing


My team has been having a lot of issues trying to get our Limelight up and running. We’ve flashed it and tried scanning for it with the finder tool, but nothing comes up. We can’t connect to it through limelight.local:5801. We’ve tried refreshing and reinstalling all of the suggested downloads on the quick start page, including Bonjour, but I’m running out of ideas. Re-flashing it hasn’t helped, and it couldn’t be detected when connecting it to our computer via Ethernet. The quick start page suggests trying to find it using Angry IP, but I don’t know what address ranges to scan through, if it can be narrowed down at all. Any suggestions?

Try the Limelight Finder Tool. It’s at the top of the downloads page: Downloads – Limelight for FRC. I’ve found that it pretty much always picks up on the limelight as long as its on the same network and powered on. Once it gives you the ip, you should be able to re-configure it or go directly to the ip.

We tried using the Limelight Finder Tool, but it doesn’t detect it. The limelight is definitely powered on, but I’m not sure how to check if its on the same network. It is connected to a network switch via Ethernet, which is then connected to the RIO.

When you say definitely on what does that look like? Our fan was on but not the led lights. Turned out there was a short on the circuit board. We are working with the company to get it resolved.

If you haven’t already done so, try following this procedure.

Both the leds are on, the fan is on, and the status lights are on.

These are the steps that we’ve been following, but the finder doesn’t detect the limelight and we cant access it at limelight.local:5801. We’ve redone the whole process multiple times but no luck.

OK, good to know. Have you done the part under “How do I reset the IP address?” If not, try that.

Other things to try are directly plugging the network into the PC you are using (shouldn’t matter, but eliminates an unknown), ensuring other networks (WiFi, etc.) and firewalls are off on this PC, or even trying a different PC. If you can, use the “arp -a” and “ipconfig -a” commands to collect information on the network, as seen by the PC, and post this here.

Check the cabling/connectors. If none of this helps, it certainly could be the limelight – but odds are it’s something else. This should help to eliminate some of the other possibilities and maybe provide some clue…

Alright, thanks for the suggestions. We’ll try this out later and post the network info.

1 Like

Just to be sure, the network switch is connected to a radio, not just to a rio with no radio correct?

1 Like

Yes, the radio, rio, and limelight are all connected to the switch.


We were able to connect to the limelight through Ethernet after disabling Wi-Fi. The Limelight Finder tool was able to detect the Limelight and we changed the settings:

After that, we power cycled the robot and attempted to access after the Limelight had booted up, but we couldn’t access it. The Limelight orange status light changed to solid from blinking, so we know that it got a static address. We tried turning off the Limelight, connecting it back to the network switch, and connecting the computer to the radio through Wi-Fi. We still couldn’t access the IP address.

We’ve reset the LL’s address multiple times and were able to connect to it through ethernet immediately afterwards, but whenever we changed the settings and rebooted it, we could not connect to it at the IP address we’d set.

Here are some of the arp -a results (top is when connected to ethernet after changing LL settings, bottom is when connected to radio after changing LL settings):


I probably made an error somewhere along the way, but I’m not sure where.

Progress! You are probably pretty close at this point.

The “ipconfig /all” info might be helpful (paste that please, when connected to the radio). First, try bringing up the driver station and setting your team number, if you have not already done this. And, you probably want to have the radio back in the picture – things are better in the bottom picture you supplied. Here’s an article with a lot of good information. Be sure that if you have a(nother) camera, it is not also set to

You might also try connecting wirelessly to the radio. If none of this helps, it might be good to go over how things are connected to the radio, the onboard switch, etc.

What limelight firmware version are you using? There was an issue with the 2020.3 Limelight firmware with setting a static IP. I don’t think I’ve tested to see if the 2020.4 version still has the issue.

I’m using version 2020.4.

We tried testing again and got some of the ipconfig info. The issues persisted.

Connected to radio:

We also tried using the other Limelight we have, which was working when it was connected to another robot. We’d already flashed it with the latest firmware and gone through the setup process a couple of weeks back, so it has a static IP, but we can’t connect to it either. We reset it to dynamic and were able to connect to it through an Ethernet connection, like the other one, but that was it.

This is the ipconfig info from Ethernet connection with second LL:

I doubt these screenshots provided enough info, but I can get some more tomorrow once we have a proper team meeting.

Here are a few more things to check:

  • Radio is not still configured for an event (as a bridge – you want access point);
  • You do not have some kind of proxy set up in the browser you are using (try a different browser, if you have one);
  • Try plugging the Limelight directly into the port on the radio closest to the power jack, or into the Power-Over-Ethernet cord if you are using one in that port;
  • Try issuing the command ping /4 and report the result;
  • Send a snapshot of the Diagnostics Tab on the driver station.

If none of that helps, go ahead and get pictures of the switch you are using and all the network connections on the robot, while you are there.

I would try flashing the Limelight down to 2020.2 and see if setting a static IP works on that version.

I found the issue. One of the ethernet cables coming out from the switch was connected back into the switch. Everything worked fine once we made sure stuff was plugged in correctly. I’m sorry that it ended up being something so stupid, but we really appreciate all the help.


This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.