Issues with getting response from jaguars and victors

We have tried programming our robot in C++ and Labview so far this year, with C++ our driver station had communications, robot code and the e stop but nothing worked, the victors and jaguars continued to flash and the code essentially did nothing. With LabView, we get a live camera stream, the driver station once again displays communications, code and the e stop, BUT once again the jaguars and victors continue to flash and the robot code is not working. Any suggestions whether coding or wiring to what could be wrong?

There are a number of things I can think of, any one of which could cause the problem.

You didn’t enable the robot on the driver station
You didn’t plug the PWM cables from the jaguar to the digital sidecar PWM ports
You didn’t power the digital sidecar
The digital sidecar isn’t plugged into the digital module in slot 4 of the cRIO

Ooohh. Joe’s already gotten all the low hanging fruit. I’d check all his suggestions first, then check this list:

You have the PWM cables plugged in backwards. B is for black wire.
You have a problem in your code that’s tripping the watchdog. Your driver station should say “Watchdog not fed” for this one.
You have the PWM cables plugged into the wrong PWM ports on the digital sidecar.

Um, also check to make sure you have the modules in the right slots. Earlier tonight we had the analog and digital modules reversed. <blush, blush>