Issues with MPLAB 7.30

At http://www.ifirobotics.com/rc.shtml (all the way at the bottom) it said not to use a MPLAB Version greater than 7.20:

NOTE: To Compile 2004, 2005 or 2006 code, use MPLAB ver 7.20 and C18 Compiler ver 2.40 (newer versions can not be used)

Does anyone know why?

I ask because MPLAB 7.30 supports Subversion (for version control), while 7.20 does not.

Thanks in advance,
Robinson

I use version 7.21, and it works fine thus far. It may simply be that it is unsupported.

Newer versions of the C18 compiler cannot be used. It’s fine to use a more up to date MPLAB.

Thanks.

Tested a few versions of the code with 7.30, works fine (as does svn!)

SVN is nice.

Yes, 7.30 works, although the compiler that comes with it might not work… which would be the problem.