Issues with New WPILib Simulation GUI

I’ve just written some basic velocity drive code which I’d like to begin testing using the simulator provided with WPILib. I’ve been following this guide by WPILib but haven’t been able to make it work.
After getting the green “build successful” message, I’m getting this error:

java.io.IOException: wpiHaljni could not be loaded from path or an embedded resource. attempted to load for platform /osx/x86-64/

    at edu.wpi.first.wpiutil.RuntimeLoader.loadLibrary(RuntimeLoader.java:79)
    at edu.wpi.first.hal.JNIWrapper.<clinit>(JNIWrapper.java:25)
    at edu.wpi.first.wpilibj.RobotBase.startRobot(RobotBase.java:207)
    at frc.robot.Main.main(Main.java:27)`

According to @Peter_Johnson, the simulator GUI should work fine for Mac, so I don’t think that’s the issue. I appreciate any help.

Edit:
(this is my first attempt at any kind of software-based testing, so please let me know if you have any other tips on how to go about testing something like this)

1 Like

We haven’t released the 2020 version of the tools so simulator will not work quite yet. Look for a blog post sometime this week with release information. Once the software has been released and you have followed the installation instructions, try to run the simulator again.

1 Like

Oh, I should have realized I was still working with the 2019 tools. I’ll be looking out for that blog post – thanks!

I tried installing the new gradle tools, and the simulateJava gradle command works great, but when I tried opening the GUI with the simulateExternalJava command, it didn’t open any dialogs. I’m on Mac in IntelliJ (tried in VSCode but same problem).

This still holds true.

4 Likes