Issues with setting up Jaguars for CAN

When I pull up BDC-Comm it connects to the Jaguar but does not populate any of the information fields, does not allow me to assign CAN ID’s, or do anything else for that matter (flashing firmware, etc.)

Since it doesn’t seem to put the Jaguar into assignment mode when I press the button at all, it seems that it’s detecting something on that serial port but not actually “connecting.” It remains in slow-blink mode, rather than solid yellow indicating a connection.

The same equipment; cables, terminator, adapter, etc. was working last year.

I’ve checked the terminating resistor with a multimeter, and it works properly.

I’ve tried reinstalling the USB-to-serial drivers, and tried multiple computers. It should also work properly.

I think the issue may be in the Serial-to-RJ12 adapter, but from what I can tell it was wired correctly. And like I said, it worked last year.

Using BDC-Comm 107.

Any thoughts?

EDIT: just found this thread, my symptoms are almost identical except we can never make it to assignment mode

How many jaguars are hooked up? Try to get communication on a single one (serial plugged in to left port, terminator in right) first. If you can communicate with it, write down its ID. Move onto the next, until you verify that you can or cannot talk with each as a single node, and record their ID’s along the way. It would be a good idea to do the firmware flash to v.107 at this time.

You may have had bad luck with your bridging jaguar. Testing the serial of each will tell you if it is a jaguar problem or a Windows / USB-Serial adapter problem. If you can’t talk with any individual ones, then the problem is with driver conflicts which prevent BDC-Comm from doing its thing. If you can talk to each, then the problem is with the CAN bus. Since it won’t show your bridging jaguar’s ID, then I suspect the problem to be windows-related or a problem within your bridge jaguar.

I’m only doing one at a time, “update firmware” is greyed out, no trusted logo, the Jaguar LED doesn’t go solid indicating a connection though BDC does say “connected.”

I had a similar issue with one Jag earlier this year. Turns out it was a bad Jag and I RMAed it. All the others that I connected with the same setup worked just fine.

You mentioned you’re doing this one Jag at a time. Have you tried others besides the one you’re having this problem with?

Yes, 3 of them.

Just because i cant rule out you not forgetting anything, is the first jag in the sequence black? I spent 3 hours this year figuring out that was my problem.

All of our Jaguars are black, 2 of them are made by Vex (with the white FIRST logo on the vent) and the other 4 were made by TI.

We ended up accidentally breaking the Serial-to-RJ12 adapter in the process of trying to look inside it, so we’ll be making a new one anyway. Maybe that will fix it…

We’ve been plagued with similar issues, and got it to work with just one black Jaguar connector. Just a couple hours ago we found that the RJ12 cable is the problem (where it plugs into the Jaguar)… pushing on it (towards the fan) gets it to work. Still no dice with more than one Jaguar on the bus though.

Someone at Vex told me last week that the PC boards on these units are conformal coating and some of that got oversprayed on the connectors. I’ll investigate tomorrow how to clean that off.


That’s interesting, I’ll have to keep that in mind.

I’m not sure if that was part of our issue though since I also tried some of the 2011-12 black Jaguars from TI to no avail.

Is your test with the TI units with a re-built serial to RJ-12 adapter?

As a complete aside, we use the 2CAN, and are extremely happy with the quick diagnostics it gives us. We even use it sometimes in conjunction with the serial adapter, as we can look at the bus from the other end. Problems like these, where you have no real indication where the problem may be, are very frustrating.

It just occurred to me that there are ways of testing your USB-Serial adapter. You can make a RS-232 loopback adapter out of a DB9 plug, where pin 2 and 3 are wired together. Firing up Hyper Terminal (not sure this is in Windows 7), and pointing it at your adapter’s port, should allow you to see that you have two-way communication. Whatever you type should be returned through the loopback. This is a simple and relatively cheap way to verify that the USB-serial adapter is working. NI has a page that describes this and other loopback configurations.

No, we won’t get the new serial adapter until tomorrow or Wednesday.

If we don’t have any issues using PWM tomorrow then we’re not going to risk changing it later on.

We have exactly the same problem. When we plug in black jaguars into BDC-Comm they seem to to react. However out of our 6 or 7 jaguars 3 of them don’t work and 3 or 4 do work with BDC-Comm. We are using the exact same procedure and we have tried multiple computers, multiple versions of BDC-COMM, multiple serial can wires and multiple terminators. All jaguars work perfectly, they just cannot be update to v107 or have their ID changed.